Please be aware that if your first version of VoIP client was deployed using APS 2.22 or 2.30, automatic upgrade of your newer VoIP client with the latest version of APS 2.3.1 will fail.

Workaround is to advice end-users to first remove your VoIP application manually from application manager and then install the newer version.

Automatic upgrade works from APS 2.20, but not from 2.22 or 2.30 ... to 2.3.1 or later release.