Hi everyone,
Could you please take a look at the problem I am having. My application composes an MMS message with 4 slides, each slide with a PNG image and a text: "1" - on the first slide, "2" - on the second and so on. The generated SMIL plays fine in REAL player, but on the handsets I tested with, it is received as 5 slides:
1 slide: Only text "1", no image
2 slide: Only PNG image, no text
3 slide: Only text "4", no image
4 slide: Only text "3", no image
5 slide: Only text "2", no image

The SMIL:
Code:
<?xml version="1.0" encoding="UTF-8"?>  
<smil xmlns="http://www.w3.org/2000/SMIL20/CR/Language">  
  <head>  
    <meta  
      content="png.png,1308,5:text0.txt,1,5:text1.txt,1,5:text2.txt,1,5:text3.txt,1,5"  
      id="mediainfo" name="mediainfo"/>  
    <layout type="text/smil-basic-layout">  
      <root-layout/>  
      <region fit="meet" height="50%" id="imageRegion" left="0%"  
        top="0%" width="100%"/>  
      <region fit="scroll" height="50%" id="textRegion" left="0%"  
        top="50%" width="100%"/>  
    </layout>  
  </head>  
  <body>  
    <par dur="5s">  
      <img begin="0s" end="5s" region="imageRegion" src="png.png"/>  
      <text begin="0s" end="5s" region="textRegion" src="text0.txt"/>  
    </par>  
    <par dur="5s">  
      <img begin="0s" end="5s" region="imageRegion" src="png.png"/>  
      <text begin="0s" end="5s" region="textRegion" src="text1.txt"/>  
    </par>  
    <par dur="5s">  
      <img begin="0s" end="5s" region="imageRegion" src="png.png"/>  
      <text begin="0s" end="5s" region="textRegion" src="text2.txt"/>  
    </par>  
    <par dur="5s">  
      <img begin="0s" end="5s" region="imageRegion" src="png.png"/>  
      <text begin="0s" end="5s" region="textRegion" src="text3.txt"/>  
    </par>  
  </body>  
</smil>
If I send 4 jpg images, it renders correctly on the handsets. I also have the same problem with some other messages, from looking at the SOAP message, it looks like when the message displays incorrectly on the handset, the order of slides is determined by the order of the SOAP parts, not the XML-defined elements from SMIL. Any advice would be very much appreciated!