×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Oct 2004
    Posts
    9

    problem with installing app to the media card

    Hello All,

    I need to transfer some files into the app's private folder, so i
    use the following command in the pkg file:
    "..\data\folders\<file_name>" -"!:\private\<SID>\<file_name>"
    This works for me fine until i installing app onto the SD card.
    Seems that installer can't crate "private" folder, nor <SID> folder.

    Any ideas how to cure it, Sirs?

  2. #2
    Super Contributor
    Join Date
    Oct 2005
    Posts
    739

    Re: problem with installing app to the media card

    Hi,

    Are you installing the whole application to SD card or just forcing some files to saved in SD card while installing to the phone memory?

    Regards,
    Peter

  3. #3
    Registered User
    Join Date
    Oct 2004
    Posts
    9

    Re: problem with installing app to the media card

    Quote Originally Posted by peter_k_john
    Hi,

    Are you installing the whole application to SD card or just forcing some files to saved in SD card while installing to the phone memory?

    Regards,
    Peter
    i'm installing the whole application.
    i use private folder to store project's specific files which are required to be deleted during uninstallation process.

    Regards,
    Dima.

  4. #4
    Super Contributor
    Join Date
    Oct 2005
    Posts
    739

    Re: problem with installing app to the media card

    Quote Originally Posted by dimak2003
    i'm installing the whole application.
    i use private folder to store project's specific files which are required to be deleted during uninstallation process.

    Regards,
    Dima.
    Is your instllation is completing or you are getting an error message in half way of the installation process.? If getting error message, what is it?

    Peter

  5. #5
    Registered User
    Join Date
    Oct 2004
    Posts
    9

    Re: problem with installing app to the media card

    no error messages.

  6. #6
    Registered User
    Join Date
    Oct 2004
    Posts
    9

    Re: problem with installing app to the media card

    no error messages.

  7. #7
    Super Contributor
    Join Date
    Oct 2005
    Posts
    739

    Re: problem with installing app to the media card

    Quote Originally Posted by dimak2003
    no error messages.
    I think you are getting the "installation complete" message. Can you show your PKG file here.?

    Peter

  8. #8
    Registered User
    Join Date
    Oct 2004
    Posts
    9

    Re: problem with installing app to the media card

    Quote Originally Posted by peter_k_john
    I think you are getting the "installation complete" message. Can you show your PKG file here.?

    Peter
    Sure, here it is
    ===============================================
    ;Language - standard language definitions
    &EN

    ; standard SIS file header
    #{"Rss"},(0xE4AA1EA0),1,0,0

    ;Localised Vendor name
    %{"Vendor-EN"}

    ;Unique Vendor name
    :"Vendor"

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>

    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\Rss.exe" -"!:\sys\bin\Rss.exe"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\Rss.rsc" -"!:\resource\apps\Rss.rsc"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\Rss_reg.rsc" -"!:\private\10003a3f\import\apps\Rss_reg.rsc"
    "$(EPOCROOT)epoc32\data\z\resource\apps\Rss.mif" -"!:\resource\apps\Rss.mif"
    "$(EPOCROOT)epoc32\data\z\resource\apps\Rss_icons.mbm" -"!:\resource\apps\Rss_icons.mbm"

    "..\data\folders\Entertainment" -"!:\private\E4AA1EA0\Entertainment"
    "..\data\folders\Mobile" -"!:\private\E4AA1EA0\Mobile"
    "..\data\folders\Bookmarks" -"!:\private\E4AA1EA0\Bookmarks"
    "..\data\folders\News" -"!:\private\E4AA1EA0\News"
    "..\data\folders\Sport" -"!:\private\E4AA1EA0\Sport"
    "..\data\folders\Technology" -"!:\private\E4AA1EA0\Technology"

    ===============================================

    Dima

  9. #9
    Super Contributor
    Join Date
    Oct 2005
    Posts
    739

    Re: problem with installing app to the media card

    Hi,

    What types of files are these? I mean filextension. I think we need to mention file extension also in pkg file (both in source and target path)

    like "..\data\folders\Entertainment.txt" -"!:\private\E4AA1EA0\Entertainment.txt"

    Regards,
    Peter

  10. #10
    Registered User
    Join Date
    Oct 2004
    Posts
    9

    Re: problem with installing app to the media card

    Quote Originally Posted by peter_k_john
    Hi,

    What types of files are these? I mean filextension. I think we need to mention file extension also in pkg file (both in source and target path)

    like "..\data\folders\Entertainment.txt" -"!:\private\E4AA1EA0\Entertainment.txt"

    Regards,
    Peter
    Hi,

    those are xml files without extensions.

    Private folder appeared on SD Card during installation after card refomatting.
    strange :-\

    thanx for help!

    Dima.

Similar Threads

  1. Problem with Media Key N70
    By michaelhansen_79 in forum Symbian
    Replies: 0
    Last Post: 2006-11-08, 15:33
  2. N80 memory card problem after update
    By fjorge_ht in forum General Development Questions
    Replies: 6
    Last Post: 2006-11-04, 16:59
  3. Installation problem on Memory Card in OS 9.1
    By saji_iq in forum Symbian
    Replies: 5
    Last Post: 2006-11-01, 10:57
  4. Problem MMC+USB Connection
    By Fede81 in forum General Development Questions
    Replies: 3
    Last Post: 2006-07-19, 15:21
  5. Run App on Uninstall problem
    By JamesLockett in forum Symbian
    Replies: 1
    Last Post: 2006-07-07, 12:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •