×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Apr 2007
    Posts
    42

    xml deploying error

    I am doing client server application in j2me(midp) its running smoothly in local host, but when i change the url to the original server there is an error in the emulator "the requasted url is not available " .But iam properly put all the classfiles and database to the server and also properly deploy the servlet files in to the web.xml file.


    error in the emulator is pasted below
    {


    <html><head><title>Apache Tomcat/4.1.31 - Error report</title><STYLE><!--H1{font-family : sans-serif,Arial,Tahoma;color : white;background-color : #0086b2;} H3{font-family : sans-serif,Arial,Tahoma;color : white;background-color : #0086b2;} BODY{font-family : sans-serif,Arial,Tahoma;color : black;background-color : white;} B{color : white;background-color : #0086b2;} HR{color : #0086b2;} --></STYLE> </head><body><h1>HTTP Status 503 - Servlet Gensearch is currently unavailable</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>Servlet Gensearch is currently unavailable</u></p><p><b>description</b> <u>The requested service (Servlet Gensearch is currently unavailable) is not currently available.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/4.1.31</h3></body></html><html><head><title>Apache Tomcat/4.1.31 - Error report</title><STYLE><!--H1{font-family : sans-serif,Arial,Tahoma;color : white;background-color : #0086b2;} H3{font-family : sans-serif,Arial,Tahoma;color : white;background-color : #0086b2;} BODY{font-family : sans-serif,Arial,Tahoma;color : black;background-color : white;} B{color : white;background-color : #0086b2;} HR{color : #0086b2;} --></STYLE> </head><body><h1>HTTP Status 503 - Servlet Gensearch is currently unavailable</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>Servlet Gensearch is currently unavailable</u></p><p><b>description</b> <u>The requested service (Servlet Gensearch is currently unavailable) is not currently available.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/4.1.31</h3></body></html>
    820
    }

    anybody can you help me .

  2. #2
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: xml deploying error

    Hi remo123,

    Well, it will help more if you can provide the original (localhost) and remote (ip) URLs just to make sure they are right and the only diference is the ip part.

    Besides, note that HTTP status codes in the 500s are errors by the server, so it seems your servlet is not deploying properly. Just another tip is that there is no way to deploy a servlet to web.xml, you can declare Servlets there but the deployment is made to the Java EE web container.

    Br,
    Juarez Alvares Barbosa Junior - Brazil

  3. #3
    Registered User
    Join Date
    Apr 2007
    Posts
    42

    Re: xml deploying error

    Thanks for the replay,

    localhost URL is "http://localhost:8080/cbs/gensearch" , its working smoothly

    and the server URL is "http://www.medclik.com:8080/cbs/gensearch"

    or

    "http://203.199.75.42:8080/cbs/gensearch"

  4. #4
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: xml deploying error

    Hi,

    The URLs seem to be right as the only diference is the IP. So, once again, make sure that your servlet is deploying properly on the remote server. You can also use the administration console of your application server and see if it is deployed and registered correctly.

    Br,
    Juarez Alvares Barbosa Junior - Brazil

Similar Threads

  1. retrieve GSM cell id
    By ibec in forum Symbian Networking & Messaging (Closed)
    Replies: 312
    Last Post: 2012-06-10, 06:45
  2. My BuilderX (with S60 SDK 2.1.NET MS version) cannot build ARMI UREL
    By danielvidonyi@hotmail.com in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-05-04, 21:30
  3. Dialogs within Symbian 6.0 based SDK
    By georgica1979 in forum Symbian User Interface
    Replies: 14
    Last Post: 2003-04-07, 15:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×