×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2007
    Posts
    4

    Unhappy Can not connect to SNAP Emulator

    Hello
    I try to do the MazeRacer example in WTK 2.5.1
    I started Nokia SNAP Emulation Evironment 2.1.3
    started Start->Start Server
    Than started MazeRacer try to connect

    No connection.

    I did not change any preferences. Checked all
    port numbers ok.

    But it does not work.

    Please can anybody help me!

    I am developing on Windows XP.

    Best Regards

    Gerhard

  2. #2
    Regular Contributor
    Join Date
    Mar 2006
    Posts
    59

    Re: Can not connect to SNAP Emulator

    Hello Gerhard,

    I checked into the sample app JAD file which currently has the following configuration:

    MIDlet-Name: SnapMobileSample
    MIDlet-Version: 1.4.1
    MIDlet-Vendor: NGS
    MIDlet-Jar-URL: SnapMobileSample.jar
    MIDlet-Jar-Size: 178801
    MIDlet-1: SnapMobileSample, /SnapMobileSample.png, samples.commui.CommUITest
    MicroEdition-Configuration: CLDC-1.0
    MicroEdition-Profile: MIDP-2.0
    SNAP-Mobile-Host: 10.10.13.26
    SNAP-Mobile-OperatorID: 012345
    SNAP-Mobile-SKU: 1
    Small-Maze: false
    Stat-Count: 3
    Stat-1: TOTAL_TIME
    Stat-2: WINS
    Stat-3: LOSSES

    Define the SNAP-Mobile-host as "localhost" and the application should start working:

    MIDlet-Name: SnapMobileSample
    MIDlet-Version: 1.4.1
    MIDlet-Vendor: NGS
    MIDlet-Jar-URL: SnapMobileSample.jar
    MIDlet-Jar-Size: 178801
    MIDlet-1: SnapMobileSample, /SnapMobileSample.png, samples.commui.CommUITest
    MicroEdition-Configuration: CLDC-1.0
    MicroEdition-Profile: MIDP-2.0
    SNAP-Mobile-Host: localhost
    SNAP-Mobile-OperatorID: 012345
    SNAP-Mobile-SKU: 1
    Small-Maze: false
    Stat-Count: 3
    Stat-1: TOTAL_TIME
    Stat-2: WINS
    Stat-3: LOSSES

    This should get you started.

    Cheers!

    - Heidi

  3. #3
    Registered User
    Join Date
    Mar 2007
    Posts
    4

    Re: Can not connect to SNAP Emulator

    Thank you very much Heidi,

    now it works.

    The problem was, that I used the version of SnapSample
    from the wtk.

    Now I use the version which is part of snap sdk,
    with your changes, and it works

    Best Regards

    Gerhard

Similar Threads

  1. Replies: 0
    Last Post: 2007-03-23, 18:39
  2. How to config Emulator Nokia series60 to connect to internet
    By x1054 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-09-07, 11:28
  3. how do i set up the 9200 emulator to connect to the internet
    By vinayakak in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2005-03-10, 10:50
  4. Unable to connect to the internet via 2.1v emulator
    By asheraslan in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2005-02-27, 17:53
  5. Can't connect to a standard http adress with emulator
    By balle3201 in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2004-04-19, 19:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×