×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2006
    Posts
    30

    link error in Visual Studio and Carbide

    when i try to link with visaul studio i have this errro :
    all is ok in command line .
    Have you got an idea ?

    Journal de génération


    ------- Génération démarrée : Projet : xcv1, Configuration : Deb_S60_31_WINSCW|Win32 -------

    Lignes de commande


    Création du fichier temporaire "c:\Symbian\9.2\S60_3rd_FP1\Examples\xcv1\Deb_S60_31_WINSCW\BAT000039.bat" avec pour contenu
    [
    @echo off
    RCMake.exe "C:\Symbian\9.2\S60_3rd_FP1\Examples\xcv1\xcv1.vcproj" S60_31 WINSCW UDEB
    if errorlevel 1 goto VCReportError
    goto VCEnd
    :VCReportError
    echo Project : error PRJ0019: Un outil a retourné un code d'erreur à partir de "Exécution d'un événement avant génération..."
    exit 1
    :VCEnd
    ]
    Création de la ligne de commande "c:\Symbian\9.2\S60_3rd_FP1\Examples\xcv1\Deb_S60_31_WINSCW\BAT000039.bat"
    Création du fichier temporaire "c:\Symbian\9.2\S60_3rd_FP1\Examples\xcv1\Deb_S60_31_WINSCW\RSP00003A.rsp" avec pour contenu
    [
    /OUT:"C:\Symbian\9.2\S60_3rd_FP1\\Epoc32\release\winscw\udeb\Xcv1.app" /NOLOGO /LIBPATH:"C:\Symbian\9.2\S60_3rd_FP1\\Epoc32\release\winscw\udeb" /DLL /NODEFAULTLIB /INCLUDE:"?_E32Dll@@YGHPAXI0@Z" /DEBUG /ASSEMBLYDEBUG /PDB:"./xcv1.pdb" /SUBSYSTEM:WINDOWS /ENTRY:"_E32Dll" /NDSProjectFile "C:\Symbian\9.2\S60_3rd_FP1\Examples\xcv1\xcv1.vcproj" /NDSSDKShortName S60_31 libxcv.lib euser.lib apparc.lib cone.lib eikcore.lib avkon.lib ws32.lib bitgdi.lib fbscli.lib eikcoctl.lib estlib.lib efsrv.lib ezlib.lib edll.lib kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib \Symbian\9.2\S60_3rd_FP1\Examples\libxcv\libxcv.lib
    .\deb_s60_31_winscw\DoubleBufferedArea.obj
    .\deb_s60_31_winscw\DrawTimer.obj
    .\deb_s60_31_winscw\KeyHandler.obj
    .\deb_s60_31_winscw\xcv1Application.obj
    .\deb_s60_31_winscw\xcv1AppUi.obj
    .\deb_s60_31_winscw\xcv1AppView.obj
    .\deb_s60_31_winscw\xcv1Document.obj
    .\deb_s60_31_winscw\xcv1Engine.obj
    .\deb_s60_31_winscw\xcv1Main.obj
    .\deb_s60_31_winscw\xcv1.uid.obj
    ]
    Création de la ligne de commande "link.exe @c:\Symbian\9.2\S60_3rd_FP1\Examples\xcv1\Deb_S60_31_WINSCW\RSP00003A.rsp"

    Fenêtre Sortie


    Exécution d'un événement avant génération...
    * Current build configuration: WINSCW UDEB
    Converting multi-icons...
    Compiling resources...
    File C:\Symbian\9.2\S60_3rd_FP1\Epoc32\release\winscw\UDEB\z\resource\apps\xcv1.rSC up-to-date, not rebuilt.
    Édition des liens en cours...
    /OUT:"C:\Symbian\9.2\S60_3rd_FP1\\Epoc32\release\winscw\udeb\Xcv1.app" /NOLOGO /LIBPATH:"C:\Symbian\9.2\S60_3rd_FP1\\Epoc32\release\winscw\udeb" /DLL /NODEFAULTLIB /INCLUDE:"?_E32Dll@@YGHPAXI0@Z" /DEBUG /ASSEMBLYDEBUG /PDB:"./xcv1.pdb" /SUBSYSTEM:WINDOWS /ENTRY:"_E32Dll" /NDSProjectFile "C:\Symbian\9.2\S60_3rd_FP1\Examples\xcv1\xcv1.vcproj" /NDSSDKShortName S60_31 libxcv.lib euser.lib apparc.lib cone.lib eikcore.lib avkon.lib ws32.lib bitgdi.lib fbscli.lib eikcoctl.lib estlib.lib efsrv.lib ezlib.lib edll.lib kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib \Symbian\9.2\S60_3rd_FP1\Examples\libxcv\libxcv.lib
    .\deb_s60_31_winscw\DoubleBufferedArea.obj
    .\deb_s60_31_winscw\DrawTimer.obj
    .\deb_s60_31_winscw\KeyHandler.obj
    .\deb_s60_31_winscw\xcv1Application.obj
    .\deb_s60_31_winscw\xcv1AppUi.obj
    .\deb_s60_31_winscw\xcv1AppView.obj
    .\deb_s60_31_winscw\xcv1Document.obj
    .\deb_s60_31_winscw\xcv1Engine.obj
    .\deb_s60_31_winscw\xcv1Main.obj
    .\deb_s60_31_winscw\xcv1.uid.obj
    Error in linking: La r‚f‚rence d'objet n'est pas d‚finie … une instance d'un objet.
    xcv1 : error PRJ0003 : Erreur lors de la génération dynamique 'link.exe'.

    Résultats


    Le journal de génération a été enregistré à l'emplacement "file://c:\Symbian\9.2\S60_3rd_FP1\Examples\xcv1\Deb_S60_31_WINSCW\BuildLog.htm"
    xcv1 - 1 erreur(s), 0 avertissement(s)

  2. #2
    Super Contributor
    Join Date
    Jun 2004
    Location
    SymbianLand
    Posts
    763

    Re: link error in Visual Studio and Carbide

    I atleast cannot cannot interpret the language of the error messages,is it spanish or italian?
    Could post some english version of the same?
    --Mayur.

  3. #3
    Registered User
    Join Date
    May 2006
    Posts
    30

    Re: link error in Visual Studio and Carbide

    Hi thanks but i have foudn the problem, i need to have on emissing library ,
    Thnaks a lot
    ERIC

Similar Threads

  1. Carbide.vs with Visual Studio 6
    By RunL in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2006-09-14, 11:12
  2. Visual Studio C++ and carbide.vs problem
    By fset_darkwing in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2006-06-21, 16:44
  3. Carbide VS does not work with studio 2005
    By KlaarMobileEntertainment in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-05-04, 08:28
  4. Visual Studio .NET 2003 Standard OR Professional
    By johnward1978 in forum Mobile Web Site Development
    Replies: 0
    Last Post: 2006-03-14, 17:48
  5. Issues with Carbide vs 2.0 installer!
    By kt10208 in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2006-01-16, 09:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •