×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Regular Contributor
    Join Date
    Aug 2004
    Posts
    295

    (solved!) [defect report] perforce plugin not working in carbide.c++ project explorer

    Hi,

    The "The Perforce Plug-in for Eclipse" doesn't work very will with carbide.c++.

    Subversion plugin works fine with Carbide.C++. It adds version control features (additional file state icons and additional commands) to project explorer. However, when using Perforce plugin, the project explorer doesn't have them.

    Perforce plugin is only usable using from Perforce perspective in Carbide. This is quite limited, because for example one has to change the perspective to open file for edit.

    I believe there is something wrong in Carbide that doesn't play will with Perforce plugin. Sure, it might be a Perforce plugin problem, but the plugin does work in regular Eclipse, so something is different in Carbide. It is unclear if this is Carbide or Perforce plugin problem.


    If Carbide dev team could perhaps investigate this issue, so if this is indeed Perforce problem, I can then address them about this.


    (I've emailed about this before directly to dev team, hopefully this forum posts gets more attention).
    Last edited by simo.salminen; 2007-08-28 at 12:41.

  2. #2
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: [defect report] perforce plugin not working in carbide.c++ project explorer

    Perforce works fine with Carbide, you must however remember to share the project using "Team|Share Project"

    Also, remember to go to Windows|Preferences, Under "General|Appearance|Label Decoration" and configure how you want the decoration in the tree view to be displayed.

    The Perforce plugin manual is also quite useful in the help system. "Help|Help Contents|Perforce SCM"

  3. #3
    Regular Contributor
    Join Date
    Aug 2004
    Posts
    295

    Re: [defect report] perforce plugin not working in carbide.c++ project explorer

    This rocks, thanks!


    (To clarify if someone stumbles to this problem, right-click on project at C/C++ Projects window, then select Team->Share Project).

Similar Threads

  1. Need of a working browser plugin
    By afelon in forum Symbian
    Replies: 10
    Last Post: 2008-02-15, 05:28
  2. Error with makesis.exe and creating the .pkg file
    By gramya87 in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2007-10-10, 13:53
  3. [newbie here] Link error
    By xitpu in forum Symbian
    Replies: 3
    Last Post: 2007-01-24, 16:53
  4. SIP ECOM plugin not working on Nokia 6600?
    By marcel_kok555 in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2006-01-25, 10:58
  5. Replies: 6
    Last Post: 2004-09-17, 14:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×