I was wondering what the proper way to use Audio Proxy Server 2.31 in an application that should work on both S60 3rd MR and S60 3rd FP1 phones is.

The versions in the two different plugin packages are different, but an application compiled with the FP1 version seems install and run fine on both MR phones (tested on an E70 and a N80) and FP1 phones (N95).

Can we use that version and sign the application without problems?

Or do we have to make two different version and sign the separately? (Alternatively I guess we could make the audio code into a DLL, compile two different versions and choose one on installation?)