When requesting http://myserver:8080 using the toolkit browser, the request-URI is empty. The browser should request '/', that is on the web server should have 'GET / HTTP/1.1' and not 'GET HTTP/1.1 HTTP/0.9'.

This worked fine for Toolkit 3.0.

From RFC2616 for HTTP/1.1: Note that the absolute path
cannot be empty; if none is present in the original URI, it MUST be
given as "/" (the server root).

We have tested this with Tomcat4.0.6 and with Jetty4.1.

There is a work-around by requesting http://myserver:8080/, but this is highly unsatisfactory.

There is a second severe bug with Toolkit 3.1, which is that if cookies are enabled on the browser, then the web server is misled into thinking the browser can handle cookies, when in fact it is not storing cookies. For this reason, sessions fail, as the session ID is being lost by the server in between requests.

This worked fine for Toolkit 3.0.

It is very unfortunate that you have withdrawn the excellent Toolkit 3.0 and disabled downloaded versions in the field. Regression testing should occur before replacing a toolkit, and even more so if you disable existing versions.

Thanks,
Mike Manning