×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Oct 2006
    Posts
    10

    sysinfo capabilities required?

    I added a call to sysinfo.ring_type() to my program (to figure out if I'm in silent profile or not), and now the program just crashes at startup when packaged in my own SIS with full devcert capabilities.

    If I run the script via the script shell, it works fine.

    Oh yeah. The call to sysinfo.ring_type() is not called immediately when the program starts up. It's burried in a function that is only called later on. Just the fact that it _exists_ in the program anywhere causes the crash at startup.

    Pys60 v1.4.0

    There seems to be a HUGE GAPING HOLE in the pys60 documentation, namely how on earth are we supposed to know what capabilities are required for each function/method call? And worse, the program just crashes and returns to the Menu. How are some people reporting that they get a KERRPermissionDenied or such messages?? It's almost impossible to debug a program by changing a single line, repackaging, uploading to the phone, re-installing, and trying to run it again, ad infinitum.

    What capability could sysinfo be requiring that is not included in LocalServices, Location, NetworkServices, PowerMgmt, ProtServ, ReadUserData, SurroundingsDD, SWEvent, UserEnvironment, WriteUserData, ReadDeviceData, TrustedUI, WriteDeviceData ?
    Last edited by iemorgan; 2007-09-08 at 19:35. Reason: add more info

  2. #2
    Super Contributor
    Join Date
    May 2006
    Location
    Oulu, Finland
    Posts
    622

    Re: sysinfo capabilities required?

    Hey iemorgan,

    http://www.lfdm.net/thesis/index.php...d-capabilities

    Try with the selfsigned application at first and if it does not work then go to an unsigned version that you will need to sign with your own developer certificate.

    LFD
    Devices:
    Nokia E61 3rd Edition - pys60 1.4.0

    Tips and modules:
    http://www.lfdm.net/thesis

  3. #3
    Registered User
    Join Date
    Oct 2006
    Posts
    10

    Re: sysinfo capabilities required?

    I did that. When devcert signed version failed, I tried a self-signed version and it still failed. I tried devcert again, with more limited capabilities but it would fail to install. Once enough theoretical capabilities have been granted that the app installs, it will crash on startup. But the same script run via the script shell works fine. I'm stumped.

  4. #4
    Registered User
    Join Date
    Oct 2006
    Posts
    10

    Exclamation Re: sysinfo capabilities required? (Symbian PlatSec or Ensymble py2sis bug?)

    OK, now I am flabbergasted. BUG in Ensymble py2sis?!

    This generates an app that crashes on startup:

    Code:
    ensymble_python2.3-0.23.py py2sis --icon=smsremind_icon_plain.svg \
    --shortcaption='SMSRemind' --caption='SMS Remind' --appname='SMS Remind' \
    --cert=../symbian-devcert.cer --privkey=../symbian-devcert.key --verbose \
    --caps=\
    LocalServices+\
    Location+\
    NetworkServices+\
    PowerMgmt+\
    ProtServ+\
    ReadUserData+\
    SurroundingsDD+\
    SWEvent+\
    UserEnvironment+\
    WriteUserData+\
    ReadDeviceData+\
    TrustedUI+\
    WriteDeviceData \
    smsremind.py
    This works: (!)

    Code:
    ensymble_python2.3-0.23.py py2sis --icon=smsremind_icon_plain.svg \
    --shortcaption='SMSRemind' --caption='SMS Remind' --appname='SMS Remind' \
    --cert=../symbian-devcert.cer --privkey=../symbian-devcert.key --verbose \
    --caps=\
    LocalServices+\
    Location+\
    NetworkServices+\
    PowerMgmt+\
    ProtServ+\
    ReadDeviceData+\
    ReadUserData+\  
    SurroundingsDD+\
    SwEvent+\  
    TrustedUI+\
    UserEnvironment+\
    WriteDeviceData+\
    WriteUserData \
    smsremind.py

    Changing the order of the caps is the only difference!!! Is Symbian PlatSec really that broken, or is this a bug in Ensymble py2sis?

  5. #5
    Super Contributor
    Join Date
    May 2004
    Location
    Tampere, Finland
    Posts
    524

    Re: sysinfo capabilities required? (Symbian PlatSec or Ensymble py2sis bug?)

    Quote Originally Posted by iemorgan View Post
    OK, now I am flabbergasted. BUG in Ensymble py2sis?!

    ...

    Changing the order of the caps is the only difference!!! Is Symbian PlatSec really that broken, or is this a bug in Ensymble py2sis?
    That's interesting. What capability bitmasks Ensymble prints in each case (the line with "Capabilities 0xNNNN")?

    Anyway, the script shell environment is different from standalone programs. See my post in this thread for a troubleshooting aid, an exception harness around your program: http://discussion.forum.nokia.com/fo...ad.php?t=99623

Similar Threads

  1. Updated list of required capabilities for API's?
    By mayur_24 in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 9
    Last Post: 2008-05-13, 13:30
  2. S60 2nd to 3rd/ PlatformSecurity / Capabilities
    By jarkoos in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 4
    Last Post: 2007-04-14, 14:08
  3. Required capabilities for SIP UA
    By rami75lu in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2007-02-13, 08:44
  4. Problem with Cabride.c++ v1.1
    By markovuksanovic in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2007-01-24, 20:05
  5. Replies: 1
    Last Post: 2006-09-04, 13:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×