×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Regular Contributor
    Join Date
    Oct 2006
    Location
    Espoo-Finland
    Posts
    71

    Central repository installation problem

    Hi,
    I have problem installing Central Repository sis file on E60.

    I have followed SymbianSigned instruction:
    Code:
    Check whether the package is an update to the Central Repository (i.e. the UID is specified as the Symbian-owned 0x10202BE9).
    If it is, additional checks must be made on the PKG file and the contents of the .SIS file.
    • If the package contains any binaries, it may not be signed.
    • The package should only contain .txt file(s) which are named in the format ‘12345678.txt’ where 12345678 is a valid protected range UID.
    These UIDs should be verified as belonging to the developer submitting the package.
    Only if all these conditions are met can the package be signed.
    Before I installed sis file following line:
    Code:
    iRepository = CRepository::NewL(TUid::Uid(KMySettingsUid));
    failed with error KErrNotFound.
    I have installed signed sis file with only one text file (as described in SDK). During installation I got error message:
    Application not compatible with phone. Continue anyway?.
    I have selected OK and sis files installs.
    If I run program after it it does not fail on line
    Code:
    iRepository = CRepository::NewL(TUid::Uid(KMySettingsUid));
    It succesfuly reads data from repository.
    I have modified repository file data and created new sis file. I have created new sis file,install, etc..
    When I run program it gets old data from repository. Repository is not updated.

    How to create sis file which will install without problem?
    How to delete repository file?

    Thanks,
    Zdenko

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,692

    Re: Central repository installation problem

    Quote Originally Posted by zdenko View Post
    Application not compatible with phone. Continue anyway?
    Try adding a pre-requisite to the .pkg (the "Series60ProductID"-line).

  3. #3
    Regular Contributor
    Join Date
    Oct 2006
    Location
    Espoo-Finland
    Posts
    71

    Re: Central repository installation problem

    Thanks.

    It was the problem.
    It instals now without error message.

    Zdenko

Similar Threads

  1. Installation problem for S60 3.0 SDK
    By harri_salminen in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2007-11-14, 22:01
  2. carbide.j 1.5 installation problem on Windows 2003
    By damoncher in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2006-09-22, 01:12
  3. Nokia 3250: Application/Themes installation problem
    By talk2arpit in forum Mobile Java General
    Replies: 3
    Last Post: 2006-09-12, 22:24
  4. Series 40 Developer Kit installation problem
    By livingston in forum Mobile Java General
    Replies: 0
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×