×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Oct 2007
    Posts
    10

    widget openURL dont work

    Im working on the newest Release of the S60 Platform SDK for C++ (336MB, released 09/10/2007).

    I try to call methode widget.openURL("www.golem.de") in a simple widget; But i get this error message on the emulator: "Application closed AppArcServerThread KERN-EXEC 3 + System error". The same error i got on the this SDK (but for Java MIDP) too

    Nokia announced, that the WRT Engine in this release should fully work. But it dont seem like so!

    Any suggestion?

  2. #2
    Registered User
    Join Date
    Nov 2003
    Posts
    1

    Re: widget openURL dont work

    On the emulator, you cannot launch the browser process from a widget due to emulator limitations. This should work on hardware.

    Sriram

  3. #3
    Registered User
    Join Date
    Oct 2007
    Posts
    10

    Re: widget openURL dont work

    Oh oh . What can man do now. There is no Features Pack 2 Device on the markt now and a lot of features dont work on the emulator. Man can not debug javascript on the emulator. I feel developing widget with this SDK is not easy

  4. #4
    Regular Contributor
    Join Date
    May 2007
    Location
    Finland
    Posts
    134

    Re: widget openURL dont work

    tunggad, you are one of the pioneers here clearing the path for those who get on later. Have you tried the Remote Device Access There are WRT enabled devices with network access available.

  5. #5
    Registered User
    Join Date
    Feb 2005
    Location
    Belgium (Europe)
    Posts
    1,352

    Re: widget openURL dont work

    Quote Originally Posted by tunggad View Post
    Im working on the newest Release of the S60 Platform SDK for C++ (336MB, released 09/10/2007).

    I try to call methode widget.openURL("www.golem.de") in a simple widget; But i get this error message on the emulator: "Application closed AppArcServerThread KERN-EXEC 3 + System error". The same error i got on the this SDK (but for Java MIDP) too

    Nokia announced, that the WRT Engine in this release should fully work. But it dont seem like so!

    Any suggestion?
    After one year and the new S60 SDK FP2 always the same error
    What a pity you can't test the browser on the emulator

    Cyke64
    pys60 1.4.5 and 2.0.0, pygame, PyS60 CE on E90 and 5800 !

    Find my pys60 extension modules on cyke64.googlepages.com

Similar Threads

  1. Replies: 2
    Last Post: 2004-04-27, 10:36
  2. CommConnection does not work with Series 60 SDK, but works in JWT
    By jackiechan2001 in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2004-02-04, 09:07
  3. Does SDK v2.0 work on Series60 V6.1?
    By liying in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2004-02-02, 08:57
  4. does irda function work with the emulator ?
    By IGhost in forum Symbian
    Replies: 0
    Last Post: 2002-12-07, 17:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •