×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Jul 2007
    Posts
    34

    Unable to install

    hello
    I am trying to port a Series 60 2.0 application to S60 v3.0
    in detail, i have modified the code a bit and trying to run it on E61i with 3rd Ed SDk, MR.

    I am getting the error "Unable to install"
    From Antonys blog, I found that this happens "when the installation file (.sis/.sisx) copies files to other application's private folder, i.e. \private\uid."

    This is from my pkg file:
    "D:\Symbian\9.1\S60_3rd_MR\Epoc32\release\gcce\urel\natware.exe"-"!:\System\Apps\Natware\natware.exe";, FILERUN, RUNINSTALL
    ".\java\nask.jar"-"!:\temp\nask.jar", FILEMIME, "application/java-archive"
    What went wrong here? I tried commenting the line
    ".\java\nask.jar"-"!:\temp\nask.jar", FILEMIME, "application/java-archive"
    then also it dint work.

    Somebody please help me.
    stay hungry, stay foolish :-)

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: Unable to install

    Although \system\apps\<appname> is not really useful on 3rd edition (.exe-s and .dll-s are supposed to be deployed into \sys\bin), based on this excerpt the installation itself should go fine.
    Could you post the whole .pkg file?

  3. #3
    Registered User
    Join Date
    Jul 2007
    Posts
    34

    Re: Unable to install

    Here it is:
    ; Languages
    &EN

    ;natware.pkg
    #{"NAT Simple Server Socket"},(0x1000004A),1,0,0

    ;Supports Series 60 2.0
    ;(0x1020216B), 2, 0, 0, {"Series60ProductID"}
    [0x101F7961], 0, 0, 0, {"S60ProductID"}

    ;Localized Vendor Name
    %{"My Test EN"}

    ;Unique Vendor name
    :"Vendor"

    "D:\Symbian\9.1\S60_3rd_MR\Epoc32\release\gcce\urel\natware.exe"-"!:\System\Apps\Natware\natware.exe";, FILERUN, RUNINSTALL
    ".\java\nask.jar"-"!:\temp\nask.jar", FILEMIME, "application/java-archive"
    stay hungry, stay foolish :-)

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,336

    Smile Re: Unable to install

    As Wizard_hu_ suggested, it should be rather in \sys\bin
    "D:\Symbian\9.1\S60_3rd_MR\Epoc32\release\gcce\urel\natware.exe"-"!:\sys\bin\natware.exe", FILERUN, RUNINSTALL
    Moreover regarding UID, please refer to this snippet from SDK help:
    It is important to remember the two UID ranges used in the context of Symbian OS v9.1 onwards: the protected range and the unprotected range.

    When an application is to be Symbian Signed (either during development using a Developer Certificate or via the Symbian Signed program) it must use a UID from the protected range. Specifically, the 0 range (0x00000000 to 0x0FFFFFFF) has been reserved for development purposes, and new UID allocations are made from the 2 range (0x20000000 to 0x2FFFFFFF). Before being submitted for Symbian Signed testing, an application must have a UID allocated from the 2 range.

    When an application is self-signed it must use a UID from the unprotected range. Specifically, the E range (0xE0000000 to 0xEFFFFFFF) has been reserved for development purposes, and new UID allocations are made from the A range (0xA0000000 to 0xAFFFFFFF). Before being released to end users, a self-signed application must have a UID allocated from the A range. For more information on the application UIDs, go to www.symbiansigned.com.
    Reference: S60 3rd MR SDK help
    And it is better practice to suffix UID in the .Exe name. Like:
    natware_0xYourUID.exe

    Kiran.

  5. #5
    Registered User
    Join Date
    Jul 2007
    Posts
    34

    Re: Unable to install

    thanx a lot for your help.
    Now i am able to install it.

    I was getting an update error but i found from our forum that its due to the change in exe UID in my package file. Then I removed the application and installed it fresh. Installation went ahead without any issues. But its not appearing in 'installed programs'. If you go to application manager, you can see the app there, can view the log, certificate, and can remove it. But cant open it.

    Why is this happening?

    I am using S60 3rd MR SDK, on E61i, developer signed.
    stay hungry, stay foolish :-)

  6. #6
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,336

    Smile Re: Unable to install

    Quote Originally Posted by dee_viz View Post
    thanx a lot for your help.
    Now i am able to install it.

    I was getting an update error but i found from our forum that its due to the change in exe UID in my package file. Then I removed the application and installed it fresh. Installation went ahead without any issues. But its not appearing in 'installed programs'. If you go to application manager, you can see the app there, can view the log, certificate, and can remove it. But cant open it.

    Why is this happening?

    I am using S60 3rd MR SDK, on E61i, developer signed.
    Is it a console based exe? Does it have any GUI component?
    Try with simple "Helloworld GUI application". Then learn the behavior of it and implement the same for your application.

    Kiran.

  7. #7
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: Unable to install

    Non-GUI executables can be also put into the menu via providing a registration resource. Check http://discussion.forum.nokia.com/fo...ad.php?t=96375 for an example.

Similar Threads

  1. Unable To Install
    By SlonUA in forum Mobile Java Networking & Messaging & Security
    Replies: 6
    Last Post: 2007-04-25, 13:46
  2. Replies: 1
    Last Post: 2007-04-16, 11:05
  3. Unable to install Yahoo Go, Gmail after formatting
    By popophobia in forum General Development Questions
    Replies: 2
    Last Post: 2007-03-14, 09:10
  4. unable to install jar
    By stevenpannell in forum Mobile Java General
    Replies: 5
    Last Post: 2006-11-10, 17:26
  5. Unable to install S60 Nokia Theme Studio 1.2
    By TheDarkus in forum Mobile Java Tools & SDKs
    Replies: 9
    Last Post: 2006-01-02, 16:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •