×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 23
  1. #1
    Regular Contributor
    Join Date
    Jun 2007
    Posts
    54

    im stuck upon installation of my 1st SISX

    I already got certificate and applied it.
    I use ensymble as batchfile to. Here is teh batch file to create my first SISX run>>

    python ensymble25.py signsis --execaps=LocalServices+Location+NetworkServices+PowerMgmt+ProtServ+ReadUserData+SurroundingsDD+SWEvent+UserEnvironment+WriteUserData+ReadDeviceData+TrustedUI+WriteDeviceData --cert=easytext.cer --privkey=easytext.key --passphrase=12345 easytext_unsign.sis easytext_signed.sis

    It compile ok.

    but upon installation, it show
    "when install my 1st 3rd edition SIS it prompted me "COMPONENT 'python for s60' missing continue anyway?"

    HELP please.

  2. #2
    Super Contributor
    Join Date
    May 2004
    Location
    Tampere, Finland
    Posts
    524

    Re: im stuck upon installation of my 1st SISX

    Quote Originally Posted by rsf View Post
    but upon installation, it show
    "when install my 1st 3rd edition SIS it prompted me "COMPONENT 'python for s60' missing continue anyway?"
    Can anybody else see this? I've yet to install PyS60 1.4.1 on my N95, but at least with PyS60 1.4.0 installed this warning is never displayed.

  3. #3
    Super Contributor
    Join Date
    May 2004
    Location
    Tampere, Finland
    Posts
    524

    Re: im stuck upon installation of my 1st SISX

    OK. Now I tested the new PyS60 1.4.1 on a Nokia E50 and could not reproduce this message. Are you sure you have the latest PyS60 installed on your phone?

  4. #4
    Regular Contributor
    Join Date
    Jun 2007
    Posts
    54

    Re: im stuck upon installation of my 1st SISX

    Actually, installing the two PYTHON program to my E50 is ok.

    My problem occur on installing my first SIS program. its signed already (all capabilties).

    Please help

  5. #5
    Super Contributor
    Join Date
    May 2004
    Location
    Tampere, Finland
    Posts
    524

    Re: im stuck upon installation of my 1st SISX

    What version of PyS60 and what version of Ensymble are you using?

  6. #6
    Regular Contributor
    Join Date
    Jun 2007
    Posts
    54

    Re: im stuck upon installation of my 1st SISX

    im using ensymble2.5.

    if you want, i can attached the actual SIS that produce from my py.

    please help.

  7. #7
    Super Contributor
    Join Date
    May 2004
    Location
    Tampere, Finland
    Posts
    524

    Re: im stuck upon installation of my 1st SISX

    Quote Originally Posted by rsf View Post
    im using ensymble2.5.
    Um, as of this writing, the latest version of Ensymble is v0.24. And if you have PyS60 v1.4.0 or v1.4.1 installed on your phone, no warning should be displayed during installation. I installed an Ensymble-generated SIS file on my E50 and indeed there was no warning. The phone had PyS60 v1.4.1 installed.

  8. #8
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    67

    Re: im stuck upon installation of my 1st SISX

    Quote Originally Posted by jethro.fn View Post
    Can anybody else see this? I've yet to install PyS60 1.4.1 on my N95, but at least with PyS60 1.4.0 installed this warning is never displayed.
    I ran into this as well. When you compile the PyS60 package yourself and sign it with a devcert, the UIDs for the packages end up being the "beta" ones that differ from the officially nokia signed packages.

    cmd_py2sis.py line 587 defines (and documents) the dependancy. However, when using the recommended 'squeezed' version you cannot easily change this.

  9. #9
    Super Contributor
    Join Date
    May 2004
    Location
    Tampere, Finland
    Posts
    524

    Re: im stuck upon installation of my 1st SISX

    Quote Originally Posted by nlsp View Post
    I ran into this as well. When you compile the PyS60 package yourself and sign it with a devcert, the UIDs for the packages end up being the "beta" ones that differ from the officially nokia signed packages.
    For this special case you can use Ensymble v0.22, if you do not need the features introduced in v0.24 (--autostart, --vendor, infoe32). Better yet, change the PyS60 project UIDs to the new ones and recompile.

  10. #10
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    67

    Re: im stuck upon installation of my 1st SISX

    Quote Originally Posted by jethro.fn View Post
    Better yet, change the PyS60 project UIDs to the new ones and recompile.
    I'll probably do so when i got a good reason to recompile

    Thanks for the good work anyway.

  11. #11
    Regular Contributor
    Join Date
    Jun 2007
    Posts
    54

    Re: im stuck upon installation of my 1st SISX

    thanks to all of you guys!

    Sorry to jetro, im using ensymble .24

    to you guys, i therefore conclude that I need to use the .22 instead of .24 or as jetro sugestion, i need to "Better yet, change the PyS60 project UIDs to the new ones and recompile."

    How to do it using ensymble .22?

  12. #12
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    67

    Re: im stuck upon installation of my 1st SISX

    Quote Originally Posted by rsf View Post
    thanks to all of you guys!

    Sorry to jetro, im using ensymble .24

    to you guys, i therefore conclude that I need to use the .22 instead of .24 or as jetro sugestion, i need to "Better yet, change the PyS60 project UIDs to the new ones and recompile."

    How to do it using ensymble .22?
    No, you shouldn't. If you run python 1.4.1, use ensymble .24, and it works, why would you?

  13. #13
    Regular Contributor
    Join Date
    Jun 2007
    Posts
    54

    Re: im stuck upon installation of my 1st SISX

    i use pys60 ver 1.41 and "ensymble_python2.5-0.22.py" to create my SISX for my E50 application.

    After successful creation, i install the output file (SIS), it shows this message >>"COMPONENT 'python for s60' missing continue anyway?"


    this is the command line is used >>
    python ensymble25.py py2sis --uid=0x0CFFFFFF --appname="Easytext" -shortcaption="My App." --caption="My Application" --version=1.2.3 --verbose et


    where:
    et -> is the folder name where i put all necessry SIS to be inclued on my package. My original "et.py" is renamed as "default.py" since the compiler is asking for it.

    ensymble25.py -> i renamed it originally ensymble_python2.5-0.22.py


    Please help me. Im stuck here.

  14. #14
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    67

    Re: im stuck upon installation of my 1st SISX

    Give it a try with ensymble_python2.5-0.24.py ??

  15. #15
    Regular Contributor
    Join Date
    Jun 2007
    Posts
    54

    Re: im stuck upon installation of my 1st SISX

    quote:

    "Give it a try with ensymble_python2.5-0.24.py ??"

    Yes, i used that one. I renamed it to ENSYMBLE25.PY so that it will be short filename.

    It creates SIS, but once install my SIS it gives me this message ""COMPONENT 'python for s60' missing continue anyway?"


    What is wrong?

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 5
    Last Post: 2007-10-22, 18:10
  2. sisx file - 3rd edition
    By Bill_Murray in forum Symbian C++
    Replies: 2
    Last Post: 2007-05-05, 15:24
  3. Carbide.c++ and installation of Nokia S60 3rd Edition SDK
    By mitesh_thakkar in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2007-04-19, 14:20
  4. Installation Problem on the Nokia 6600
    By ManishPatil in forum Symbian C++
    Replies: 1
    Last Post: 2005-02-02, 09:51
  5. NDS 2.0 Installation Problem
    By morozov in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2003-11-12, 22:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •