×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Super Contributor
    Join Date
    Mar 2003
    Posts
    1,733

    Problem Starting the server

    Posted by Gustavo Felisberto, humpback@d-attitude.com
    on July 16, 2000 at 21:36

    I downloaded the WAP toolkit and installed it, all works fine (local pages) but to see remote pages I need to run the start_server_sim.bat. I altered the file so it would find the java components (I did not install it to c: but to e:), but when I run the script I get this:

    E:PROGRA~1NokiaWAP_Toolkit_2.0>rem -------------------------------------

    E:PROGRA~1NokiaWAP_Toolkit_2.0>rem Server Simulator script For Win98

    E:PROGRA~1NokiaWAP_Toolkit_2.0>rem -------------------------------------

    E:PROGRA~1NokiaWAP_Toolkit_2.0>set JAVADIR=e:Progra~1JavaSoftJRE1.2

    E:PROGRA~1NokiaWAP_Toolkit_2.0>set JAVA_LIB=e:Progra~1JavaSoftJRE1.2lib

    E:PROGRA~1NokiaWAP_Toolkit_2.0>set JAVA_EXE=e:Progra~1JavaSoftJRE1.2binjava.exe

    E:PROGRA~1NokiaWAP_Toolkit_2.0>if not exist e:Progra~1JavaSoftJRE1.2binjava.exe goto out_bad

    E:PROGRA~1NokiaWAP_Toolkit_2.0>cd ServerSimulator

    E:PROGRA~1NokiaWAP_Toolkit_2.0ServerSimulator>deltree /y config*.*

    E:PROGRA~1NokiaWAP_Toolkit_2.0ServerSimulator>deltree /y logs*.*

    E:PROGRA~1NokiaWAP_Toolkit_2.0ServerSimulator>set path=libi386;libi386;libi386;libi386;C:WINNTsystem32;C:WINNT;C:WINNTSystem32Wbem

    E:PROGRA~1NokiaWAP_Toolkit_2.0ServerSimulator>set cp=libwapminisrv.jar;libactivation.jar;libjsdk.jar;libmail.jar;

    E:PROGRA~1NokiaWAP_Toolkit_2.0ServerSimulator>e:Progra~1JavaSoftJRE1.2binjava.exe -classpath libwapminisrv.jar;libactivation.jar;libjsdk.jar;libmail.jar; com.nokia.wap.gw.manager.MiniServerManager

    -----------------------------------------------------------------------------
    Nokia WAP Server Simulator
    (based on)

    Nokia WAP Server 1.0.2 (build 2091)

    Copyright (c) Nokia Corporation 1999. All rights reserved.
    -----------------------------------------------------------------------------

    Java Version: 1.2.2 / Sun Microsystems Inc.
    Character Set: Cp1252
    Virtual Machine: Classic VM 1.2.2 / Sun Microsystems Inc.
    Operating System: Windows NT 5.0

    ServerSimulator: Loading libraries
    ServerSimulator: loading serverJNIdll
    ServerSimulator: loading wmlencoderJNI
    ServerSimulator: loading wmlsencoderJNI
    ServerSimulator: loading servlib
    ServerSimulator: loading nativeBearerJNI
    ServerSimulator: loading capcodecJNI
    ServerSimulator: loading headercodecJNI
    ServerSimulator: Initialising Server components
    ServerSimulator: Initialisation of Server components completed
    --------------------------------------------------------
    ServerSimulator: Server initialised, starting traffic
    ServerSimulator: Traffic start failed: Component Startup failed
    No bearer adapters could be started
    ServerSimulator: Server initialised. Traffic is stopped

    E:PROGRA~1NokiaWAP_Toolkit_2.0ServerSimulator>goto out_ok

    E:PROGRA~1NokiaWAP_Toolkit_2.0ServerSimulator>echo Server Simulator Done.
    Server Simulator Done.

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Posts
    1,733

    RE: Problem Starting the server

    Posted by Gustavo Felisberto, humpback@d-attitude.com
    on July 17, 2000 at 21:35

    I solved the problem. First in w2k there is no deltree command, so I changed the deltree /y for a del /s/f/q .

    Second, the server will only start if it is started BEFORE the WAP toolkit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×