×

Discussion Board

Page 1 of 3 123 LastLast
Results 1 to 15 of 32
  1. #1
    Registered User
    Join Date
    Oct 2007
    Posts
    10

    BLDMAKE ERROR: cpp.exe returned non-zero exit status

    Hi,

    I don't know why I get
    BLDMAKE ERROR: ERROR: cpp.exe returned non-zero exit status (13568)
    Build returned with exit value=-1

    When I run HelloWorld!
    Does anybody know why?? and what I should do??
    Thank you in advance

    Adriano

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    You can try issuing
    Code:
    bldmake bldfiles
    from a command prompt in the group folder of the project.

  3. #3
    Registered User
    Join Date
    Oct 2007
    Posts
    10

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    I did
    c:\Program Files\Common Files\Symbian\tools\bldmake.exe bld.inf

    and I get
    Can't open perl script "c:\Program": No such file or directory

    What do you suggest?
    Thanks a lot,

    Adriano

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    Quote Originally Posted by adrianogalati View Post
    I did
    c:\Program Files\Common Files\Symbian\tools\bldmake.exe bld.inf

    and I get
    Can't open perl script "c:\Program": No such file or directory

    What do you suggest?
    Thanks a lot,

    Adriano
    Certainly not like that.

    Go to the "group" folder of your project directory. Call the following command.
    bldmake bldfiles
    Kiran.

  5. #5
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    62

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    Quote Originally Posted by adrianogalati View Post
    I did
    c:\Program Files\Common Files\Symbian\tools\bldmake.exe bld.inf

    and I get
    Can't open perl script "c:\Program": No such file or directory

    What do you suggest?
    Thanks a lot,

    Adriano

    A Forum Nokia Champion tells you exactly what to do, you completely ignore it and try something bizarre instead then ask for even yet furhter assistance???

  6. #6
    Registered User
    Join Date
    Oct 2007
    Posts
    10

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    Ok, thanks,
    I did it and I have got:

    This application has failed to start because cygwin1.dll was not found. Re-installing the application may fix this problem.

    and

    BLDMAKE ERROR: ERROR: cpp.exe returned non-zero exit status (13568)
    cpp.EXE -undef -nostdinc -+ -I ..\..\..\EPOC32\include -I . -I .\ ".\BLD.INF"

    But I have cygwin1.dll in C:\Symbian\8.0a\S60_2nd_FP2_CW\Epoc32\tools\migrationtool\gccbinutils

    What do you think I should do?
    Thanks,
    Adriano

  7. #7
    Registered User
    Join Date
    Jul 2009
    Posts
    2

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    Quote Originally Posted by adrianogalati View Post
    Ok, thanks,
    I did it and I have got:

    This application has failed to start because cygwin1.dll was not found. Re-installing the application may fix this problem.

    and

    BLDMAKE ERROR: ERROR: cpp.exe returned non-zero exit status (13568)
    cpp.EXE -undef -nostdinc -+ -I ..\..\..\EPOC32\include -I . -I .\ ".\BLD.INF"

    But I have cygwin1.dll in C:\Symbian\8.0a\S60_2nd_FP2_CW\Epoc32\tools\migrationtool\gccbinutils

    What do you think I should do?
    Thanks,
    Adriano
    I also have almost same problem the error "bldmake returned with exit value = 2" displays when trying to build the program. Can anyone please tell the solution!!!!! I reinstalled all the SDKs, ActivePerl and Carbide c++2.0. Help!!

  8. #8
    Registered User
    Join Date
    Jun 2009
    Posts
    10

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    It seems like your build environment is picking the C preprocessor(cpp.exe) from cygwin. I find it safe to add %EPOCROOT%epoc32/tools;%EPOCROOT%epoc32/gcc/bin ahead in the PATH environment variable. The cpp.exe is bundled in the Symbian SDK.

  9. #9
    Registered User
    Join Date
    Feb 2010
    Posts
    10

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    Can u please tell me what exactly is the "group" folder of the project directory? I'm unable to figure out where it is.

  10. #10
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    According to your other posts, you are experimenting with Qt, so expect answers in the Qt boards (yes, I can see your threads there, just I do not know Qt). It may happen that some make-like utility generates the bld.inf for you.
    Note that these command line magics may rely on having the winscw toolchain available from the command line too. In the Start Menu group of Carbide.c++ you can find "Configure environment for WINSCW command line". Try running it if you have not executed it yet (if Vista has right-click+"Run as Administrator", consider using that way to execute it).
    Have you checked if it is possible to create and execute some Qt-less, but GUI code with your configuration?

  11. #11
    Registered User
    Join Date
    Aug 2009
    Posts
    23

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    I have the same problem. I did reinstall all the SDKs, the compiler and active pearl.

    At the Carbide Console:

    Code:
    ***Invoking bldmake command
    perl.exe -S bldmake.pl bldfiles winscw  
    
    ERROR: EPOCROOT must specify an existing directory.
    
    === BLDMAKE Command failed with error code 2 ===
    ***Stopping. Check the Problems view or Console output for errors.
    
    ***Errors were detected in build. See the Problems or Console view for details.
    And when I try
    Code:
    bldmake bldfiles
    EPOCROOT environment variable must be capitalised
    BEGIN falied--compilation aborted at C:\S60\devices\Nokia_N97_SDK_v1.0\epoc32\/E32env.pm line 55.
    Compilation failed in require at C:\S60\devices\Nokia_N97_SDK_v1.0\epoc32\tools\bldmake.pl line 28.
    BEGIN failed--compilation aborted at C:\S60\devices\Nokia_N97_SDK_v1.0\epoc32\tools\bldmake.pl line 28.

  12. #12
    Registered User
    Join Date
    Aug 2009
    Posts
    23

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    I'm notexperimenting with Qt

  13. #13
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    Then it is not the same problem...
    Do you have an EPOCROOT environment variable? Because you should not. set command lists the environment variables. set e lists the variables having a name starting with 'e'.
    If you type a simple devices, does it show your SDK?

  14. #14
    Registered User
    Join Date
    Aug 2009
    Posts
    23

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    I dont have an EPOCROOT avriable.
    device work and list all the SDKs: 3rd, 5th and N97.

  15. #15
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: BLDMAKE ERROR: cpp.exe returned non-zero exit status

    Which one is set as default?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Tool exit status codes on "make"
    By newnb in forum Symbian
    Replies: 0
    Last Post: 2006-10-02, 21:55
  2. C++-Tool exit status codes during "make"
    By newnb in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2006-10-02, 21:54
  3. How can i solve this error?
    By symbian-newbie in forum Symbian
    Replies: 6
    Last Post: 2006-05-23, 05:33
  4. N70 Reset bug
    By sebboB in forum General Development Questions
    Replies: 2
    Last Post: 2005-12-28, 23:09
  5. Getting started with Carbide.vs -- running the app
    By ET3D in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2005-11-23, 17:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×