×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Sep 2007
    Posts
    40

    N75 Installation Error

    I cannot install any .sis into this phone, including the Symbian Signed application tools.

    I have a DevCert from Symbian. I sucessfully sign all .sis files. The error is not very helpful: "Unable to Install" as the phone is installing the .exe. It downloads and passes all certificate requirements.

    I have reformatted the phone thinking there may be some files installed on the ROM that are conflicting with the application. The only capabilities I am using are Network Services, ReadUserData, WriteUserData, and ReadDeviceData.

    The SID is consistent and the UID is consistent and issued by Symbian in the protected range.

    I used the GCCE UREL as the .sis build. Is that not correct? My app runs fine under the WINSCW UDEB. Am using Code Warrior V3.1 and S60_3rd_MR SDK.

    I have googled and searched all the forums, and have just purchased an ACS Publisher ID, just in case this is the problem (which I doubt).

    What am I missing?

    Thanks,

    Monica

  2. #2
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

  3. #3
    Registered User
    Join Date
    Sep 2007
    Posts
    40

    Re: N75 Installation Error

    Yes, that article has been very helpful with the other errors I encountered. But, I cannot find which files may be in conflict, since I cannot install the tools from Symbian to check the files in the phone and compare to the files in my app.

    Is there a way to check the installed files directly on the phone?

    It seems odd that Symbian would publish tools that have a file conflict and can't be installed to the device.

  4. #4
    Registered User
    Join Date
    Sep 2007
    Posts
    40

    Re: N75 Installation Error

    I can get the .sis to install if I comment out this line in my .pkg

    "c:\Symbian\9.1\S60_3rd_MR_3\Epoc32\data\Z\private\10003a3f\apps\HTTPClientExample_reg.rsc"-"
    !:\private\10003a3f\import\apps\HTTPClientExample_reg.rsc"

    so, there is something in that file or it points to something that the device does not like. How do I determine what that is? Is there a list of files someplace that I can review?

    Thanks.
    Last edited by ss7guru; 2007-11-08 at 18:34.

  5. #5
    Registered User
    Join Date
    Sep 2007
    Posts
    40

    Re: N75 Installation Error

    Ok. I had a bad path in the .pkg for the _reg.rsc.

    Works now. Thanks.

Similar Threads

  1. error LNK2019: unresolved external symbol ???
    By wgarnett in forum Symbian
    Replies: 3
    Last Post: 2009-09-28, 06:53
  2. i cant build helloworld project
    By akhin in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2008-12-22, 12:38
  3. carbidec++ helloworld project problem
    By akhin in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 0
    Last Post: 2007-03-11, 12:40
  4. [newbie here] Link error
    By xitpu in forum Symbian
    Replies: 3
    Last Post: 2007-01-24, 16:53
  5. Replies: 3
    Last Post: 2007-01-18, 11:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×