×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jul 2007
    Posts
    47

    Multiply defined symbol

    Multiply defined symbol...
    i am getting an error like this. what needs to be done to resolve this? wanted to know why this error appears? and this error comes on line 0.

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Czech Republic
    Posts
    2,037

    Re: Multiply defined symbol

    Hi,

    this happend in compilation? Doy you use proprerly #define and #ifndef pair in all header files?

    Can happen also, that you have declared something, which was already defined in symbian header files - but the compiler normally have quite descriptive output...

    BR
    STeN

  3. #3
    Super Contributor
    Join Date
    May 2006
    Location
    Beijing,China
    Posts
    1,190

    Re: Multiply defined symbol

    Quote Originally Posted by chandrasekharan View Post
    Multiply defined symbol...
    i am getting an error like this. what needs to be done to resolve this? wanted to know why this error appears? and this error comes on line 0.
    Do you define symbol in your header files?
    [I][COLOR="Orange"]xhsoldier[/COLOR][/I]
    [email]xhsoldier@gmail.com[/email]/[email]xhsoldier@163.com[/email]

  4. #4
    Regular Contributor
    Join Date
    Jun 2007
    Location
    Bangalore
    Posts
    208

    Smile Re: Multiply defined symbol

    Quote Originally Posted by chandrasekharan View Post
    Multiply defined symbol...
    i am getting an error like this. what needs to be done to resolve this? wanted to know why this error appears? and this error comes on line 0.
    Hi chandrasekharan,
    See whether u have used
    #define and #ifndef properly or not.

    if u have declared your own class then change the name of yur class, it will solve yur prob.

    these error generally come when yur framework is already using the same name.....

  5. #5
    Registered User
    Join Date
    Jul 2007
    Posts
    47

    Re: Multiply defined symbol

    thanks a lot guys.. it actually helped...

Similar Threads

  1. GoogleIt
    By deepika.mangla in forum Symbian
    Replies: 5
    Last Post: 2011-05-28, 11:04
  2. Fail to build syexpat 1.3 under 2nd FP3
    By harry_zhang in forum Symbian
    Replies: 10
    Last Post: 2010-03-19, 10:24
  3. illegal use of abstract class error...
    By kannabiran.krish in forum Symbian
    Replies: 7
    Last Post: 2007-08-17, 10:11
  4. error LNK2001: Please Help
    By sourish_khan in forum Symbian
    Replies: 9
    Last Post: 2006-04-19, 11:16
  5. S80 Platform SDK and Visual Studio .NET Linking Error
    By jayantjain in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-10-07, 22:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×