Whenever I try to test my midlet with the 7210 emulator the emu screen shows 'Application error' and in the message window it says 'Bad class access flags'. It seems this happens with every class which is an interface.

In my project that's HttpPosterListener.java which I have taken from the nokia examples without changing anything (verified by turning on 'trace class loading' in the emulator options).

The midlet runs fine with the 3410 and the 6310i emulators. I have tried to execute it directly from the JB context menu and from the Nokia Developer's Suite, both fails with the same error.

Anyone knows a solution for this strange behaviour?

UPDATE: I have succeeded in running the midlet after reinstalling just about everything for a couple of times. Then suddenly the same old error turned up again... aaaarrrghhh!!!!

A quick google search showed that numerous people do have this problemm but no one has a solution for it. Seems like different JDK versions have something to do with it.

Maybe someone from Nokia Support knows this issue???


thx
Wolfgang