×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Nov 2007
    Posts
    9

    compiling error with S40 5th edition library

    I got compiling error when I add library in netbean project, anyone had this problem. I actually had this problem before can not remember how I solved it


    ERROR: floating-point constants should not appear
    Error preverifying class com.nokia.mid.sound.Sound



    Thanks

  2. #2
    Registered User
    Join Date
    Nov 2007
    Posts
    6

    Re: compiling error with S40 5th edition library

    Hi everybody! Please help me with the following problem. I just bought a Nokia 3110 Classic and it is working well, but it cannot open jar applications more than 1Mb. I have a dictionary of 2.2Mb and I copied it on flash, but in the phone list of applications it appears crossed. My phone version is the latest one V 05.50 RM-237, the phone came with it, it is not an upgrade.

    Please help!!!

  3. #3
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: compiling error with S40 5th edition library

    Nokia 3110User, please start a new thread if you have completely different question.
    http://www.forum.nokia.com/devices/3110_classic
    Max JAR size for 3110 is 1 MB

    morningtai, are you compiling with CLDC 1.0 setting on?

    Hartti

  4. #4
    Registered User
    Join Date
    Nov 2007
    Posts
    9

    Re: compiling error with S40 5th edition library

    Quote Originally Posted by hartti View Post
    Nokia 3110User, please start a new thread if you have completely different question.
    http://www.forum.nokia.com/devices/3110_classic
    Max JAR size for 3110 is 1 MB

    morningtai, are you compiling with CLDC 1.0 setting on?

    Hartti
    yes, should I use 3110 sdk or it has same sound, ui package as s40 5th edition?

  5. #5
    Registered User
    Join Date
    Nov 2007
    Posts
    9

    Re: compiling error with S40 5th edition library

    Quote Originally Posted by hartti View Post
    Nokia 3110User, please start a new thread if you have completely different question.
    http://www.forum.nokia.com/devices/3110_classic
    Max JAR size for 3110 is 1 MB

    morningtai, are you compiling with CLDC 1.0 setting on?

    Hartti
    I got confused about nokia3110user posting question, anyway, should I use 5th edition or 3th or earlier sdks?

  6. #6
    Registered User
    Join Date
    Nov 2007
    Posts
    9

    Re: compiling error with S40 5th edition library

    Quote Originally Posted by hartti View Post
    Nokia 3110User, please start a new thread if you have completely different question.
    http://www.forum.nokia.com/devices/3110_classic
    Max JAR size for 3110 is 1 MB

    morningtai, are you compiling with CLDC 1.0 setting on?

    Hartti
    also can I use setFullScreenMode() function if I extends fullCanvas

  7. #7
    Registered User
    Join Date
    Nov 2007
    Posts
    6

    Re: compiling error with S40 5th edition library

    Hi everybody. Can somebody help me? Why my new 3110 is not opening a jar file biger than 1 mb. Yahoo GO has 1 Mb. All other apps which run well are smaler. I tried Nokia Pc Suite, but it shows me that there is no enought memory when I selected my 2Gb flash. Also, my phone has its memory free, because I am keeping everything on flash. Moreover, the phone shows the app crossed and when I am pressing ok it gives me the message:invalid application, Delete?. Is there an explanation, or is better to buy a new phone?
    Last edited by Nokia3110User; 2007-11-29 at 07:32.

  8. #8
    Registered User
    Join Date
    Nov 2007
    Posts
    9

    Re: compiling error with S40 5th edition library

    Quote Originally Posted by Nokia3110User View Post
    Hi everybody. Can somebody help me? Why my new 3110 is not opening a jar file biger than 1 mb. Yahoo GO has 1 Mb. All other apps which run well are smaler. I tried Nokia Pc Suite, but it shows me that there is no enought memory when I selected my 2Gb flash. Also, my phone has its memory free, because I am keeping everything on flash. Moreover, the phone shows the app crossed and when I am pressing ok it gives me the message:invalid application, Delete?. Is there an explanation, or is better to buy a new phone?
    ????????????????

Similar Threads

  1. GoogleIt
    By deepika.mangla in forum Symbian
    Replies: 5
    Last Post: 2011-05-28, 11:04
  2. Project upgrade from Carbide c++ 1.1 to 1.2 adds "hb" library?
    By codepatch in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2007-06-13, 20:34
  3. 6280 != S40 3rd Edition
    By henson2K in forum General Development Questions
    Replies: 0
    Last Post: 2005-07-27, 19:58
  4. Can’t launch application on 6630
    By kaffemannen in forum Symbian
    Replies: 8
    Last Post: 2005-06-29, 10:49
  5. Question about JBuilder with S40 DP 2.0 SDK, 6255 Edition 1.0
    By jbrown.eng in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-04-21, 01:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •