×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 23
  1. #1
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    84

    [moved] "unable to install. component is already built in" message on emulator.

    Hi,
    the sis file built
    the sis file is signed (self-signed )
    the emulator must have the proper root certificates

    Iam able to instll my app on the device. But while instlling on the emulator i get "Unable to instll component is built in. I have run abld really clean winscw udeb command also. Can anybody tell me why i get this message on the emulator..

    Thanks...

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Smile Re: "unable to install. component is already built in" message on emulator.

    Check this FNTL page if it helps you: SIS installation on the S60 3rd Edition emulator

    Kiran.

  3. #3
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    84

    Re: "unable to install. component is already built in" message on emulator.

    I have followed the steps in the link given ..
    Still the same problem..

  4. #4
    Registered User
    Join Date
    Aug 2003
    Location
    Oulu, Finland
    Posts
    1,122

    Re: "unable to install. component is already built in" message on emulator.

    Double check that the SIS/PKG file has no files with similar paths that already exist on emulator Z: drive.

    One question remains: why do you need to use the application installer on the emulator?

    Lauri

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: "unable to install. component is already built in" message on emulator.

    Quote Originally Posted by laa-laa View Post
    One question remains: why do you need to use the application installer on the emulator?

    Lauri
    There's a valid use case right here: to test the installation in the context of an existing pre-installed (e.g. in ROM) version.

    You are right though, for a standard installation to work the built files must be removed from the emulator first. Calling something like del /s <project_name>*.* in SDK's /epoc32 directory will solve the problem.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Registered User
    Join Date
    Oct 2007
    Posts
    18

    Re: "unable to install. component is already built in" message on emulator.

    I have deleted all my project files. Yet i get componet already built in.. Please anybody can help me installation.
    Thanks

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: "unable to install. component is already built in" message on emulator.

    Is there another application with the same UID3 in your system? Installing another instance of the SDK is one way of ensuring a clean emulator environment as long as you do not build any projects with that SDK.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  8. #8
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: "unable to install. component is already built in" message on emulator.

    I think you need to start by posting your pkg file

    Also, look in the app manager in the emulator (normally in the Installations folder) and make sure your app is not listed there.

  9. #9
    Regular Contributor
    Join Date
    Feb 2006
    Posts
    50

    Re: "unable to install. component is already built in" message on emulator.

    Quote Originally Posted by praveena_R View Post
    I have deleted all my project files. Yet i get componet already built in.. Please anybody can help me installation.
    Thanks
    Check that all files shown by command "abld -what build winscw udeb" are not there, when you try to install sis into the emulator. I think it is the resource-files or icon-file (.mif) which cause sis installation to fail with that error.

    -- ile

  10. #10
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    84

    Re: "unable to install. component is already built in" message on emulator.

    Thank you very very much. Finally i got my sis file installed on emulator successfully.

    Regards
    Rajani

  11. #11
    Registered User
    Join Date
    Jul 2008
    Posts
    2

    Re: "unable to install. component is already built in" message on emulator.

    Hi Rajani

    How your problem of "unable to install. component is already built in" is resolved. I am also facing same problem.

    Thanks
    Pankaj

  12. #12
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,752

    Re: "unable to install. component is already built in" message on emulator.

    If you have the same issue, take your time and read the thread.

  13. #13
    Registered User
    Join Date
    Feb 2008
    Posts
    209

    Re: "unable to install. component is already built in" message on emulator.

    Hi Rajni ,
    actually , i am facing same problem ,can u help me.

    Thanks,
    Neeraj

  14. #14
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,752

    Re: "unable to install. component is already built in" message on emulator.

    Quote Originally Posted by soni_neeraj View Post
    i am facing same problem ,can u help me.
    In that case you can be really happy, since the solution is already provided in this thread.

  15. #15
    Registered User
    Join Date
    Feb 2008
    Posts
    209

    Re: "unable to install. component is already built in" message on emulator.

    Quote Originally Posted by wizard_hu_ View Post
    In that case you can be really happy, since the solution is already provided in this thread.
    i solved the built in error but now i am getting "Required application access not granted" error.

    Thanks,
    Neeraj

Similar Threads

  1. Replies: 3
    Last Post: 2009-07-01, 14:30
  2. Replies: 3
    Last Post: 2009-05-11, 11:40
  3. [moved] Error in sending data from nokia emulator to servlet(server)
    By icecubebar in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2008-10-09, 09:39
  4. Self-signed application error :"Unable to install. Component is built-in"
    By hoangtv1 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 6
    Last Post: 2008-04-12, 21:47
  5. Problem during sending an MMS message to EAIF Emulator
    By wuhao2005 in forum General Messaging
    Replies: 1
    Last Post: 2003-02-24, 07:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×