×

Discussion Board

Results 1 to 15 of 23

Hybrid View

  1. #1
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    84

    [moved] "unable to install. component is already built in" message on emulator.

    Hi,
    the sis file built
    the sis file is signed (self-signed )
    the emulator must have the proper root certificates

    Iam able to instll my app on the device. But while instlling on the emulator i get "Unable to instll component is built in. I have run abld really clean winscw udeb command also. Can anybody tell me why i get this message on the emulator..

    Thanks...

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Smile Re: "unable to install. component is already built in" message on emulator.

    Check this FNTL page if it helps you: SIS installation on the S60 3rd Edition emulator

    Kiran.

  3. #3
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    84

    Re: "unable to install. component is already built in" message on emulator.

    I have followed the steps in the link given ..
    Still the same problem..

  4. #4
    Registered User
    Join Date
    Aug 2003
    Location
    Oulu, Finland
    Posts
    1,122

    Re: "unable to install. component is already built in" message on emulator.

    Double check that the SIS/PKG file has no files with similar paths that already exist on emulator Z: drive.

    One question remains: why do you need to use the application installer on the emulator?

    Lauri

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: "unable to install. component is already built in" message on emulator.

    Quote Originally Posted by laa-laa View Post
    One question remains: why do you need to use the application installer on the emulator?

    Lauri
    There's a valid use case right here: to test the installation in the context of an existing pre-installed (e.g. in ROM) version.

    You are right though, for a standard installation to work the built files must be removed from the emulator first. Calling something like del /s <project_name>*.* in SDK's /epoc32 directory will solve the problem.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Registered User
    Join Date
    Oct 2007
    Posts
    18

    Re: "unable to install. component is already built in" message on emulator.

    I have deleted all my project files. Yet i get componet already built in.. Please anybody can help me installation.
    Thanks

Similar Threads

  1. Replies: 3
    Last Post: 2009-07-01, 14:30
  2. Replies: 3
    Last Post: 2009-05-11, 11:40
  3. [moved] Error in sending data from nokia emulator to servlet(server)
    By icecubebar in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2008-10-09, 09:39
  4. Self-signed application error :"Unable to install. Component is built-in"
    By hoangtv1 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 6
    Last Post: 2008-04-12, 21:47
  5. Problem during sending an MMS message to EAIF Emulator
    By wuhao2005 in forum General Messaging
    Replies: 1
    Last Post: 2003-02-24, 07:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×