×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    May 2003
    Location
    Slovakia
    Posts
    33

    Carbide VS 3.0: ERROR: RCMake failed: (Makefile creation): No active .mmp file found.

    I ported my project from Carbide VS 2.0.1 to Carbide VS 3.0. WINS version work fine, but if I want to compile to Rel_S60_30_GCCE I got: ERROR: RCMake failed: (Makefile creation): No active .mmp file found.

    I check Carbide.VS Properties and Active mmp file is set right and content of mmp file is right. If i try to compile it from command line, compilation is done right.

  2. #2
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Carbide VS 3.0: ERROR: RCMake failed: (Makefile creation): No active .mmp file fo

    You would need to provide much more information, as this has been tested a number of times and works without any issues most of the time. Without much more information it is impossible to deduce why you are having the problem. For instance:
    - Did you try to change the active .mmp file in the VS properties?
    - What is the name and path of the .mmp file, both relative to the project as well as "absolutely"?
    Pls also post the full build log or output window content for the GCCE build.

  3. #3
    Registered User
    Join Date
    May 2003
    Location
    Slovakia
    Posts
    33

    Re: Carbide VS 3.0: ERROR: RCMake failed: (Makefile creation): No active .mmp file fo

    Quote Originally Posted by mitts View Post
    You would need to provide much more information, as this has been tested a number of times and works without any issues most of the time. Without much more information it is impossible to deduce why you are having the problem. For instance:
    - Did you try to change the active .mmp file in the VS properties?
    - What is the name and path of the .mmp file, both relative to the project as well as "absolutely"?
    Pls also post the full build log or output window content for the GCCE build.
    I didn't change anything. I add the project under Source control and GCCE REL stop compile.

    I found where was the problem:
    Piece of vcproj content:
    <?xml version="1.0" encoding="windows-1250"?>
    <VisualStudioProject
    ProjectType="Visual C++"
    Version="8,00"
    Name="MyProject"
    ProjectGUID="{67CEF6C2-A3D8-4E86-872E-8B390CF69B1B}"
    RootNamespace="MyProject"
    SccProjectName="SAK"
    SccLocalPath="..\..\..\.."
    SccProvider="XXXX:XXXX"
    Keyword="SymbianOS_3.Symbian9"
    If vcproj is connected to version control contain this section:
    SccProjectName="SAK"
    SccLocalPath="..\..\.."
    SccProvider="something"

    I think that:
    RcMake.exe take SccProjectName create SAK-SymbianOS-properties.xml and try to find SAK.mmp.

    I hope that this help.

    Patrik

  4. #4
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Carbide VS 3.0: ERROR: RCMake failed: (Makefile creation): No active .mmp file fo

    Yes, this was very helpful. So did GCCE compilation work before you checked into Source Safe? And WINS still works also after you have checked it in? In this case, the Active .mmp file name is MyProject.mmp?
    Did you try to create an .mmp file with the name of "SAK.mmp"? Does that work?

  5. #5
    Registered User
    Join Date
    May 2003
    Location
    Slovakia
    Posts
    33

    Re: Carbide VS 3.0: ERROR: RCMake failed: (Makefile creation): No active .mmp file fo

    Quote Originally Posted by mitts View Post
    Yes, this was very helpful. So did GCCE compilation work before you checked into Source Safe? And WINS still works also after you have checked it in? In this case, the Active .mmp file name is MyProject.mmp?
    Did you try to create an .mmp file with the name of "SAK.mmp"? Does that work?
    After I connected vcproj to Source Safe it stoped build GCCE (I got error No active .mmp file found), but WINS compilation still work fine.

    Yes the name of the mmp is MyProject.mmp.
    I try to create SAK.mmp with same content as MyProject.mmp, but this doesn't help, I still got error: Carbide VS 3.0: ERROR: RCMake failed: (Makefile creation): No active .mmp file found. But Carbide create SAK-SymbianOS-properties.xml:
    <?xml version="1.0" encoding="utf-8"?>
    <NDSProject xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" version="1.0" supplier="Nokia">
    <updateMmpFile>true</updateMmpFile>
    <updateUidCppFile>true</updateUidCppFile>
    <pkgFile>sis\SAK.pkg</pkgFile>
    <pkgUpdate>true</pkgUpdate>
    <pkgGeneration>true</pkgGeneration>
    <lang>EN</lang>
    <copyExportsFlag>false</copyExportsFlag>
    </NDSProject>
    But this is absolutely different from original MyProject-SymbianOS-properties.xml and in SAK-...xml is missing tag <activeMMP>

    Patrik

  6. #6
    Regular Contributor
    Join Date
    Sep 2007
    Posts
    51

    Re: Carbide VS 3.0: ERROR: RCMake failed: (Makefile creation): No active .mmp file fo

    Hi,

    Thanks for an excellent bug report, fixing this bug was very easy based on it :) So the bug is fixed, the fix will be included in a service release later this month.

    A possible workaround is to always copy MyProject-SymbianOS-properties.xml to SAK-SymbianOS-properties.xml before build. One way to make it easier is to edit the build command:

    Properties -> Configuration Properties -> NMake
    Add the following command to the start of "Build Command Line" and "Rebuild All Command Line", before "RCMake.exe ..."

    copy /y $(ProjectName)-SymbianOS-properties.xml SAK-SymbianOS-properties.xml

    Hopefully this will allow you to continue working until the service release.

    Olli

Similar Threads

  1. No library file found matching 'libedll.lib{.lib|.a}' or 'edll.lib'
    By manish_mishra2005 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 5
    Last Post: 2007-08-28, 21:23
  2. Prototype SDK 2.0 setup problem
    By jackmcardle in forum Mobile Java Tools & SDKs
    Replies: 4
    Last Post: 2007-01-09, 16:21
  3. Tips on using NDS 1.1
    By mitts in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2006-01-18, 16:07
  4. Problems with errno module
    By tsharju in forum Python
    Replies: 1
    Last Post: 2005-10-21, 11:24
  5. can not successfully link any sample using .NET
    By lobotomat in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2002-08-20, 00:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •