×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2007
    Posts
    2

    Problem to process APDU on real external smartcard

    Hello,

    we have a tricky problem to solve so now we have to call nokia community for help

    We use the Nokia 6131NFC with an external Oberthur Cosmo Dual smart card.

    1- We have installed an applet on a card successfully.
    2- We can select the applet by process an APDU SELECT command normally.
    3- But after that, when we process proprietary instructions the card always responds 9000 (OK) and seems to not process our APDUs with customized instructions.

    My questions are:
    - Is there a specific class byte to put on APDU in order to reach processAPDU method of the applet? Currently, we have set CLA to 0x00 but we have tested 0x80 too...

    - Is there a specific channel to listen on applet to get APDU from mobile phone over NFC? Perhaps with the 2 bits of channel selection, like 0x03 for example?

    Our development is an emergency, can someone help us?
    Thanks a lot!

    Romain Pellerin

  2. #2
    Registered User
    Join Date
    Dec 2007
    Posts
    2

    Re: Problem to process APDU on real external smartcard

    Hello again,

    we have fixed our problem, thanks a lot for your support!

    Regards

  3. #3
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    88

    Exclamation Re: Problem to process APDU on real external smartcard

    Hi,

    how did you solve your problem?

    More importantly, would you please (or anyone) post some links to documentation on sending APDUs to a Java Card from 6131? i.e. a J2ME Midlet communicating to an external Java Card (sending APDUs and receiving responses over ISO14443 A/B).

    Any sample code, examples would be much appreciated.

    Many thanks.

Similar Threads

  1. error LNK2019: unresolved external symbol ???
    By wgarnett in forum Symbian
    Replies: 3
    Last Post: 2009-09-28, 06:53
  2. error LNK2001: Please Help
    By sourish_khan in forum Symbian
    Replies: 9
    Last Post: 2006-04-19, 11:16
  3. S80 Platform SDK and Visual Studio .NET Linking Error
    By jayantjain in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-10-07, 22:14
  4. Sound problem in real 7650
    By cooler1 in forum Mobile Java General
    Replies: 0
    Last Post: 2002-08-13, 09:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×