×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    29

    Installed SIS to 7650 but can't find application (tried everything)

    Hello all,

    I know this has been discussed before and I have reviewed as many related posts as I can find and tried everything suggested but for some reason I am getting nowhere with it.

    I have developed an application to the point where it is running on the emulator, made a SIS file and installed it on my 7650 (via bluetooth). This all seems to go fine except I then can't find any new icon anywhere on my phone to run my application despite it showing up in the manager application which allows me to view its details and uninstall it.

    I have tried to remove all variables by just trying to install the hello world application but still have the same result.

    Based on other discussions I have tried:
    - Full path names
    - The line which is apparently needed for series 60 ((0x101F6F88), 0, 0, 0, {"Series60ProductID"})
    - Making sure my UID is the 3rd one in the list in the .uid.cpp file

    Questions:
    - Do I need a UID supplied by Symbian for this to work?
    - Is this the sort of problem a bad UID causes?
    - Are there any utilities available like a file explorer for me to at least see what is going on internally and maybe run my program manually?
    - Is the fact that I am in Australia using an Australian phone possibly a problem (eg. it won't install the UK English verion to my Australian English phone)?
    - Where is the application supposed to appear on my phone (is it in Extras?) - is there some way to dictate where it should go, eg. the main page?

    My .pkg file (minus the comments) looks like:

    -------------------------------------------
    #{"Minimal application"},(0x10008ACE),1,0,0
    (0x101F6F88), 0, 0, 0, {"Series60ProductID"}

    "C:\Symbian\6.1\Series60\Epoc32\Release\wins\UREL\Z\SYSTEM\apps\HELLOWORLD\HelloWorld.app"-"!:\system\apps\helloworld\helloworld.app"
    "C:\Symbian\6.1\Series60\Epoc32\Release\wins\UREL\Z\SYSTEM\apps\HELLOWORLD\HelloWorld.rsc"-"!:\system\apps\helloworld\helloworld.rsc"
    -------------------------------------------

    with HelloWorld.uid.cpp being:
    -------------------------------------------
    // Makmake-generated uid source file
    #include <E32STD.H>
    #pragma data_seg(".E32_UID&quot
    __WINS_UID(0x10000079,0x100039ce,0x10008ace)
    #pragma data_seg()
    -------------------------------------------

    Any help is greatly appreciated - I have already lost two full days on this.

    Thanks in advance

    Kevin Dinn

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    29

    RE: Installed SIS to 7650 but can't find application (tried everything)

    Well, fixed it myself just after posting this question.

    As the trained observer will see from my pkg file, I am trying to transfer the files built for win32 to my device. I subsequently discovered it makes more sense to build them for the ARMI architecture of the phone. :-)

    For people's info the command is: abld build armi urel
    and you transfer the files out of: Symbian\6.1\Series60\Epoc32\Release\ARMI\UREL (on my machine anyway).

    Thanks to anyone who pondered my problem anyway.

    Regards

    KD

  3. #3
    Nokia Developer Expert
    Join Date
    Mar 2003
    Posts
    91

    RE: Installed SIS to 7650 but can't find application (tried everything)

    Hey user application appear in the "others" desktop folder (unless you move it to some other folder). Does your application contains some sort of UI?

    Ashish

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×