×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: makesis error

  1. #1
    Registered User
    Join Date
    Nov 2007
    Posts
    384

    makesis error

    not avaiable
    Last edited by dinesh547; 2008-06-16 at 08:03.

  2. #2
    Super Contributor
    Join Date
    Aug 2005
    Location
    india
    Posts
    2,078

    Re: makesis error

    hi,

    it means that myMobileMedia.exe is not created at all..

    when making

    abld build gcce urel there might be some errors while building for the exe..
    can you paste the console output after the build is done so that we can know or anyone can see and reply you back..

    Regards,
    Mateen Maldar
    "Whatever the mind can conceive and believe, the mind can achieve"

  3. #3
    Regular Contributor
    Join Date
    Mar 2007
    Location
    "On a b'ful lil palnet called EARTH belongs wid Galaxy named MilkyWay in Universe"
    Posts
    402

    Post Re: makesis error

    Quote Originally Posted by dinesh547 View Post
    hello friends,
    i am getting error
    Processising mymobilemedia_3rd_gcce.pkg
    error:I/O Fault

    my .pkg file is pasted below

    i have checked the file it is in the correct folder.
    but it always says I/O fault any CLUE:I am using code warrior IDE for development and sdk is 9.1


    ; myMobileMedia_3rd.pkg
    ;
    ;Language - standard language definitions
    &EN, FR


    ; standard SIS file header
    #{"myMobileMedia-EN","myMobileMedia-FR"},(0x200086F8),3,5,2

    ;Localised Vendor name
    %{"Vendor-EN","Vendor-FR"}

    ;Unique Vendor name
    :"Vendor"

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"S60ProductID","S60ProductID"}

    ;Files to install

    ; LIBMAD
    "\Symbian\9.1\S60_3rd\epoc32\release\gcce\urel\libmad.dll"-"!:\sys\bin\libmad.dll"


    {"\Symbian\9.1\S60_3rd\Epoc32\Data\z\resource\apps\myMobileMedia.r01"
    "\Symbian\9.1\S60_3rd\Epoc32\Data\z\resource\apps\myMobileMedia.r02"
    }
    -"!:\resource\apps\myMobileMedia.rsc"
    {"\Symbian\9.1\S60_3rd\Epoc32\Data\z\resource\apps\myMobileMedia_caption.r01"
    "\Symbian\9.1\S60_3rd\Epoc32\Data\z\resource\apps\myMobileMedia_caption.r02"
    }
    -"!:\resource\apps\myMobileMedia_caption.rsc"

    {"\Symbian\9.1\S60_3rd\Epoc32\Data\z\private\10003a3f\import\apps\myMobileMedia_reg.r01"
    "\Symbian\9.1\S60_3rd\Epoc32\Data\z\private\10003a3f\import\apps\myMobileMedia_reg.r02"
    }
    -"!:\private\10003a3f\import\apps\myMobileMedia_reg.rsc"

    ;"\Symbian\9.1\S60_3rd\Epoc32\release\winscw\udeb\z\system\apps\myMobileMedia\myMobileMedia.aif" -"!:\resource\apps\myMobileMedia.aif"
    ;"\Symbian\9.1\S60_3rd\Epoc32\release\winscw\udeb\z\system\apps\myMobileMedia\myMobileMedia_xip.aif" -"!:\resource\apps\myMobileMedia_xip.aif"

    "\Symbian\9.1\S60_3rd\Epoc32\Data\z\resource\apps\player.mbm" -"!:\resource\apps\player.mbm"
    "\Symbian\9.1\S60_3rd\Epoc32\Data\z\resource\apps\player.mif" -"!:\resource\apps\player.mif"
    "\Symbian\9.1\S60_3rd\Epoc32\Data\z\resource\apps\MyMobileMedia_aif.mbm" -"!:\resource\apps\MyMobileMedia_aif.mbm"
    "\Symbian\9.1\S60_3rd\Epoc32\Data\z\resource\apps\MyMobileMedia_aif.mif" -"!:\resource\apps\MyMobileMedia_aif.mif"
    "..\..\config\S60\cmware\config.ini" -"c:\config.ini"

    ; exe
    "\Symbian\9.1\S60_3rd\epoc32\release\gcce\urel\myMobileMedia.exe" -"!:\sys\bin\myMobileMedia.exe",FR,RI


    ""-"!:\mymobilemedia.txt",FN
    ""-"!:\mymobilemedia.dbz",FN
    ""-"c:\mymobilemedia.ini",FN
    ""-"!:\Libmad.txt",FN
    ""-"c:\config.ini",FN
    well man.. juzz check the path given in ur pkg.. look r those files there in given path...
    ===With Symbian===
    "Something Has Survived..!!!"

  4. #4
    Registered User
    Join Date
    Nov 2007
    Posts
    384

    Re: makesis error

    i have alreay checked all the files they are all on places.also mymobilemedia.exe is also on place.

    Any More Clues

  5. #5
    Regular Contributor
    Join Date
    Mar 2007
    Location
    "On a b'ful lil palnet called EARTH belongs wid Galaxy named MilkyWay in Universe"
    Posts
    402

    Exclamation Re: makesis error

    Quote Originally Posted by dinesh547 View Post
    i have alreay checked all the files they are all on places.also mymobilemedia.exe is also on place.

    Any More Clues
    have u makesis.exe of 3rd edition in ur sis folder? actaully ur error is not giving any line number.. so u should try from any already running pkg code of 9.1
    ===With Symbian===
    "Something Has Survived..!!!"

  6. #6
    Registered User
    Join Date
    Nov 2007
    Posts
    384

    Re: makesis error

    there r another builds which are made successfully for same sdk.
    so i think it should nt be problem of sis.exe

  7. #7
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: makesis error

    Quote Originally Posted by dinesh547 View Post
    there r another builds which are made successfully for same sdk.
    so i think it should nt be problem of sis.exe
    "Error:I/O Fault" clearly means that it does not find the file from Source path in your .pkg file.

    It would really help you if you know the line number for I/O fault.

    Try running "makesis" command from command prompt. I hope it will list the line number, the culprit one.

    Kiran.

  8. #8
    Registered User
    Join Date
    Nov 2007
    Posts
    384

    Re: makesis error

    i have checked the folder the other files of the folder are building.the only error i am getting in given package file.i am not getting any error line no in this file.but if i put some text on the end or some other places in the .pkg file than it shows error on that line.This means that file is compiling completeley.



    Any Other Clues

  9. #9
    Super Contributor
    Join Date
    Aug 2005
    Location
    india
    Posts
    2,078

    Re: makesis error

    hi,

    the best way to know what you are doing wrong give all the absolute paths to check , if the exe is created..

    and be sure that all files exists in the absolute path of yours..

    Regards,
    Mateen Maldar
    "Whatever the mind can conceive and believe, the mind can achieve"

  10. #10
    Registered User
    Join Date
    Nov 2007
    Posts
    384

    Re: makesis error

    helllo mateen i have checked all absolute paths and all files on their respective folders.I dont understand y i am getting error I/O fault and not getting line no of the error Even all files on its place.For other .pkg files it is working fine.
    I know that my .pkg file is compiling till last since i have putted wrong text in the file and checked.It gives line no in that case if .pkg file contains an invalid character.This means my .pkg file is compiling.


    Any More CLues Regarding this problem

  11. #11
    Super Contributor
    Join Date
    Aug 2005
    Location
    india
    Posts
    2,078

    Re: makesis error

    hi,

    seems weird for me , but i suspect the exe path.. coz that's the only thing which gives IO fault without line number..

    Regards,
    Mateen Maldar
    "Whatever the mind can conceive and believe, the mind can achieve"

  12. #12
    Registered User
    Join Date
    Nov 2007
    Posts
    384

    Re: makesis error

    checked all path i even put the Absolute path in the package file for exe but still getting error.Any MORE HELP there

  13. #13
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Question Re: makesis error

    Quote Originally Posted by dinesh547 View Post
    checked all path i even put the Absolute path in the package file for exe but still getting error.Any MORE HELP there
    Even calling "makesis" from command prompt doesn't give you line number?

    Kiran.

  14. #14
    Registered User
    Join Date
    Nov 2007
    Posts
    384

    Re: makesis error

    no i am already building from cmd prompt

  15. #15
    Regular Contributor
    Join Date
    Apr 2006
    Location
    India
    Posts
    383

    Re: makesis error

    Well.. If u r using code warrior..revert back

    I feel its issue with cwlink file
    Regards,
    Shilpa Kulkarni

Similar Threads

  1. error LNK2019: unresolved external symbol ???
    By wgarnett in forum Symbian
    Replies: 3
    Last Post: 2009-09-28, 06:53
  2. Carbide.vs 2.01 Registration Problem
    By baykal in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2006-12-22, 16:55
  3. code warrior problems
    By mayankkedia in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2004-10-25, 06:59
  4. Building
    By pacman2000z in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2003-07-17, 10:44
  5. Unresolved external symbols problem
    By georgica1979 in forum Symbian User Interface
    Replies: 1
    Last Post: 2003-04-06, 13:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×