×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Jun 2007
    Location
    Bangalore
    Posts
    208

    Exclamation Exec error:Launching failed***build returned with exit value = -1

    Hi,
    when I am build the project in Carbide I am getting the following error
    "Exec error:Launching failed***build returned with exit value =-1"


    Please help me.Its urgent.
    I am looking forward for your response.

    Regards,
    Zahid

  2. #2
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399

    Re: Exec error:Launching failed***build returned with exit value = -1

    Would help if you posted the errors and/or console output from the build.

    Tim

  3. #3
    Regular Contributor
    Join Date
    Jun 2007
    Location
    Bangalore
    Posts
    208

    Re: Exec error:Launching failed***build returned with exit value = -1

    Quote Originally Posted by timm-ah View Post
    Would help if you posted the errors and/or console output from the build.

    Tim

    Dear Tim,
    I have copied the error message.

    ***Building project "myproj" for configuration "Emulator Debug (WINSCW) [S60_3rd_FP2_Beta_2]"

    ***Printing environment variables modified from default:
    PATH=D:\Program Files\Nokia\Carbide.c++ v1.2\x86Build\Symbian_Tools\Command_Line_Tools;d:\Symbian\9.3\S60_3rd_FP2_Beta_2\epoc32\tools;d:\Symbian\9.3\S60_3rd_FP2_Beta_2\epoc32\gcc\bin;D:\Perl\bin\;D:\Perl\site\bin;D:\Perl\bin\;D:\Program Files\Java\jdk1.5.0_12\bin;D:\Program Files\netbeans-5.5.1\bin;C:\Program Files\Common Files\Symbian\Tools;d:\Program Files\CSL Arm Toolchain\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;\Epoc32\gcc\bin;\Epoc32\tools; C:\Program Files\CSL Arm Toolchain\bin
    MWCSYM2INCLUDES=D:\Program Files\Nokia\Carbide.c++ v1.2\x86Build\Symbian_Support\MSL\MSL_C\MSL_Common\Include;D:\Program Files\Nokia\Carbide.c++ v1.2\x86Build\Symbian_Support\MSL\MSL_C\MSL_Win32\Include;D:\Program Files\Nokia\Carbide.c++ v1.2\x86Build\Symbian_Support\MSL\MSL_C\MSL_X86;D:\Program Files\Nokia\Carbide.c++ v1.2\x86Build\Symbian_Support\MSL\MSL_C++\MSL_Common\Include;+D:\Program Files\Nokia\Carbide.c++ v1.2\x86Build\Symbian_Support\MSL\MSL_Extras\MSL_Common\Include;D:\Program Files\Nokia\Carbide.c++ v1.2\x86Build\Symbian_Support\MSL\MSL_Extras\MSL_Win32\Include;D:\Program Files\Nokia\Carbide.c++ v1.2\x86Build\Symbian_Support\Win32-x86 Support\Headers\Win32 SDK;
    MWSYM2LIBRARIES=D:\Program Files\Nokia\Carbide.c++ v1.2\x86Build\Symbian_Support\Win32-x86 Support\Libraries\Win32 SDK;D:\Program Files\Nokia\Carbide.c++ v1.2\x86Build\Symbian_Support\Runtime\Runtime_x86\Runtime_Win32\Libs
    MWSYM2LIBRARYFILES=MSL_All_MSE_Symbian_D.lib;gdi32.lib;user32.lib;kernel32.lib;
    EPOCROOT=\Symbian\9.3\S60_3rd_FP2_Beta_2\

    Working Directory: D:/Symbian/9.3/S60_3rd_FP2_Beta_2/myproj/group

    *** Makefile structures up to date. Skipping 'bldmake bldfiles'

    ===Build Command = /c abld build WINSCW UDEB -v===
    Exec error:Launching failed***build returned with exit value = -1
    ***Stopping. Check the Problems view or Console output for errors.
    -1

    Looking forward for your reply.

    Zahid

  4. #4
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399

    Re: Exec error:Launching failed***build returned with exit value = -1

    I'm not sure. Did this ever build? You might try a clean, if that doesn't work, delete the temporary build files for the project under \epoc32\build\...

    Also make sure your Perl version is 5.6.1.

    Tim

  5. #5
    Regular Contributor
    Join Date
    Jun 2007
    Location
    Bangalore
    Posts
    208

    Re: Exec error:Launching failed***build returned with exit value = -1

    Quote Originally Posted by timm-ah View Post
    I'm not sure. Did this ever build? You might try a clean, if that doesn't work, delete the temporary build files for the project under \epoc32\build\...

    Also make sure your Perl version is 5.6.1.

    Tim
    Hi Tim,
    Thanks for your response.Ya previously it was building.I had tried every option.
    Perl version is 5.6.1. Infact I had tried with other higher version of Perl also.

    Waiting for your quick response.

    zahid

  6. #6
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399

    Re: Exec error:Launching failed***build returned with exit value = -1

    I'd delete the temporary build files (including abld.bat) and re-import the project. If it still doesn't work try importing a different project and building from command-line to rule out something specific to the current project.

    Tim

  7. #7
    Regular Contributor
    Join Date
    Jun 2007
    Location
    Bangalore
    Posts
    208

    Exec error:Launching failed***build returned with exit value = -1

    Hi Timm-ah

    Thanks for your response. No it is giving me the same error
    for every project.

    Waiting for your quick response.

    Zahid

  8. #8
    Registered User
    Join Date
    May 2003
    Posts
    3

    Smile Re: Exec error:Launching failed***build returned with exit value = -1

    I've just had exactly the same problem and I discovered that my PATH environment variable had something weird in it:

    C:\Program Files\i~ae??úŸ
    ´a;

    No idea why or how it ended up there but check yours and hopefully that will fix it.

    ----
    Nick Clarey - CEO, Airsource
    http://www.airsource.co.uk/ | http://blog.airsource.co.uk

Similar Threads

  1. PC Suite error: (Code: Init IMediaControl2) HELP?!
    By chunkyspudmonkey in forum General Development Questions
    Replies: 30
    Last Post: 2014-07-15, 05:44
  2. BLDMAKE ERROR: cpp.exe returned non-zero exit status
    By adrianogalati in forum Symbian
    Replies: 31
    Last Post: 2010-11-29, 15:31
  3. Replies: 0
    Last Post: 2007-11-01, 18:25
  4. N70 Reset bug
    By sebboB in forum General Development Questions
    Replies: 2
    Last Post: 2005-12-28, 23:09
  5. UNDESIRED Exit command key.
    By tektronic in forum Mobile Java General
    Replies: 4
    Last Post: 2005-05-13, 18:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×