×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2007
    Posts
    9

    Unhappy Java Getting started please help

    Hi,

    I originally posted this in the General Discussions Board and it was suggested that I post it here.

    I feel that all of this could have been answered by the Netbeans Screencast for Nokia devices tutorial but the file I downloaded stops after the introduction. I decided to go with Java since it is applicable on S40 platform.

    Now, I did read the getting started documents and pages but I'm still confused. It says here that I should download Netbeans IDE 5.5.1 then install Netbeans Mobility Pack. There are Two Mobility pack, CDC and CLDC. Should I install both or just the CLDC pack?

    Another problem is the compliance Issue. According here, the correct one is 1.3 or 1.4. But if I install Netbeans 5.5.1, JDK requirement is 5.0 according here.

    About SDK, If you can please confirm if I understand it correctly. Different SDK edition is required for different phone. It serves as an emulator for phones. I having 3 different Nokia edition phone need to install SDK for each phone due to code break between editions.

    I apologize for the long post but I really am lost.

    Appreciate the input.
    Thank you very much.

    koko

  2. #2
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: Java Getting started please help

    Just the CLDC pack is enough.

    There should be a setting for correct compliancy in NetBeans (so you can use JDK 5.0 as your runtime on the PC)

    Yes, you might want to test yoru MIDlet on all the target editions. And on real phones too!

    Hartti

  3. #3
    Registered User
    Join Date
    Dec 2007
    Posts
    9

    Re: Java Getting started please help

    Hello hartti,

    Thank you for replying.

    There should be a setting for correct compliancy in NetBeans (so you can use JDK 5.0 as your runtime on the PC)
    If there's a setting I can change, does this mean I can also use Netbeans 6.0 with mobility being the minimum version requirement of jdk is 5.0 or even jdk 6.0? Should I stick with Netbeans 5.5.1?

    koko
    Last edited by koko_crunch; 2008-01-04 at 12:35.

Similar Threads

  1. Replies: 0
    Last Post: 2004-11-27, 17:03
  2. can't open Nokia MMS Java Library
    By barnsley in forum General Messaging
    Replies: 3
    Last Post: 2004-08-28, 05:44
  3. unable to download "Getting started with java technology"
    By junkobanshoya in forum Mobile Java General
    Replies: 0
    Last Post: 2004-03-13, 19:16
  4. j2ME, java enabled, and the 3410
    By davidkangaroo in forum Mobile Java General
    Replies: 2
    Last Post: 2002-07-05, 22:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×