×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Nov 2007
    Posts
    19

    APS buffer with header 0?

    My observations with APS buffers:
    With (CNG -0/1 and VAD 0) -> All APS buffers always has header value 1 (Hopefully noise is also generated).

    With (CNG-0/1 and VAD 1) -> All types of header 2,1,0 are seen, with header 2 always precedes 1.

    The APS 2.4.1 doc says that header value 0 is unvoiced non-sid frame and contains body filled with zeros. But I observe a combination of both data and zeros (few data samples and zeros succeeds till the end).

    Can someone elaborate on Buffers with header value 0?
    - Can the buffer with header 0 contain samples as well as 0’s? Should we consider playing these buffers also if CNG is enabled (ideally we need not give any buffers if CNG is enabled)?

    -Even if VAD identifies noise, do we still get APS buffers with header 0 every 20ms?

  2. #2
    Registered User
    Join Date
    Sep 2006
    Posts
    10

    Re: APS buffer with header 0?

    Hi,

    Which codec are you using?

    My experience is mainly with the G.729 codec. Every silence [header 00] frame is always full of zeroes. When VAD is enabled, I get all 3 types of frames. Silence frames are always preceded by a SID update [02] frame. The decoder outputs comfort noise based on the last SID update frame until it receives a normal [01] frame or a new SID update.

    You have to keep constantly feeding the decoder new frames, even if CNG/VAD is active, otherwise it will underflow. So, if you want to play back comfort noise, send one [02] frame to the decoder followed by frames that are full of zeros.

Similar Threads

  1. Recording in Amr Format
    By losym in forum Symbian Media (Closed)
    Replies: 12
    Last Post: 2009-03-26, 06:41
  2. Audio Proxy Server v2.31 released
    By nly in forum VoIP
    Replies: 30
    Last Post: 2007-11-02, 16:34
  3. Replies: 6
    Last Post: 2005-10-03, 05:51
  4. Dialog's clipping area (again). Nokia experts, please help
    By synov in forum Symbian User Interface
    Replies: 0
    Last Post: 2004-06-26, 14:35
  5. Nokia 30 SMS sending problem !!!!!
    By pgredelj in forum General Messaging
    Replies: 1
    Last Post: 2004-01-12, 12:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×