×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Nov 2007
    Posts
    3

    Carbide.vs 3 RDebug output

    Just tried installing Carbide.vs 3 today and having trouble getting RDebug output to appear in the Output window.

    Setup:
    • Using S60_3rd_MR.
    • Breakpointing works in VS and Carbide.c++ 1.2.
    • Debug output works fine in Carbide.c++ 1.2.
    • RDebug output is going to $TEMP/epocwind.out as expected.

    But, nothing is turning up in VS output window except DLL load/unload messages like
    Command Line Args:
    The thread 'Win32 Thread' (0xdc) has exited with code 0 (0x0).
    The thread 'Win32 Thread' (0xe40) has exited with code 0 (0x0).
    The thread 'Win32 Thread' (0xa8c) has exited with code 0 (0x0).
    The thread 'Win32 Thread' (0x139c) has exited with code 0 (0x0).
    The thread 'Win32 Thread' (0x11e0) has exited with code 0 (0x0).
    The thread 'Win32 Thread' (0x173c) has exited with code 0 (0x0).
    ...
    Any suggestions?

    Another small annoyance: is it possible to get epocwrapper to stop epoc and allow to see the stack trace during a panic or Leave in carbide.vs, like happens in Carbide.c++?
    Last edited by jearl; 2008-01-21 at 13:02.

  2. #2
    Registered User
    Join Date
    Nov 2007
    Posts
    3

    Re: Carbide.vs 3 RDebug output

    Further update, works fine for me with FP1 emulator out of the box. Anyone had success with emulator from MR release?

  3. #3
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Carbide.vs 3 RDebug output

    RDebug "How to" can be found here: http://wiki.forum.nokia.com/index.php/How_to_use_RDebug

    Check if you have probs with RDebug, check that:
    - You have "LogToDebugger 1" in epoc.ini for the relevant SDK
    - in the VS output window you have selected eiher Debug of - preferable - Filtered Debug, as this gives you much less garbage in the Output.

    Note that in Carbide.vs 3.0, the filter rules for "Filtered Debug" are user settable, so you can further tailor what is shown. Carbide.vs Help will tell you how!

  4. #4
    Registered User
    Join Date
    Jun 2006
    Posts
    27

    Re: Carbide.vs 3 RDebug output

    I am having the same problem. I have already verified that I have "LogToDebugger 1" in my epoc.ini file and I've also checked out the Carbide.vs 3.0 help on Filtering the debug. The help file doesn't say anything about how to customize the output, only that you can. I dont understand what I need to change in order to get the RDebug output to display.

  5. #5
    Registered User
    Join Date
    Jun 2006
    Posts
    27

    Re: Carbide.vs 3 RDebug output

    I spoke too quicky. I modified the OutputWindowFilter.regexconf file and changed the two lines to this:

    'epoc\.exe': *

    'EpocWrapper\.exe' \(Managed\): *

    After that the filtered output window displayed the same output that I am used to seeing in Carbide.c++. I still don't understand the syntax but at least it is working now.

  6. #6
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Carbide.vs 3 RDebug output

    The syntax is regex (Regular Expression) syntax.

  7. #7
    Regular Contributor
    Join Date
    Sep 2007
    Posts
    51

    Re: Carbide.vs 3 RDebug output

    A good free tool for writing and testing regular expressions is expresso, http://www.ultrapico.com .

    For general regex tutorials you can go to http://www.regular-expressions.info/

    -Olli

Similar Threads

  1. Carbide.vs 2.0.1 and 2.0.2 Tips and Known Issues
    By mitts in forum Symbian Tools & SDKs
    Replies: 15
    Last Post: 2008-05-05, 11:57
  2. No RDebug output in Carbide.c++ console
    By pandreas81 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 7
    Last Post: 2007-11-21, 07:49
  3. Can not see output of RDebug in Carbide C++1.2!
    By antares6260 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2007-06-14, 19:16
  4. RDebug serial output on Nokia N80
    By ddskani in forum Symbian
    Replies: 3
    Last Post: 2006-12-20, 02:40
  5. Receiving RDebug output from Series60 device
    By Zaxxon in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2003-11-29, 17:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×