×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jul 2007
    Posts
    27

    help install pyd module

    i want to use akntextutils.pyd module in my 2nd edition sdk, i have put this file in lib folder as well as in python script folder.

    but while using command "from akntextutils import wrap_text_to_array" it show error 'not found',

    i have tried restarting emulator also....

    any idea how to install and use this module... ?

  2. #2
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: help install pyd module

    Try adding this:

    >>> import sys
    >>> sys.path.append(mypath)

    Where mypath should be something like 'C:\Python\', or wherever your .pyd file is located. I can't guarantee this will work as I haven't tried it except in the Python IDLE environment.

  3. #3
    Registered User
    Join Date
    Apr 2009
    Posts
    4

    Re: help install pyd module

    Hi mindstien,
    I've had the same problem of using akntextutils on S60 2nd Ed. FP3 and Simo on stackoverflow helped me out at http://stackoverflow.com/questions/2...tallation-help. When you get the *.pyd as recommended by Simo, copy that file to C:\Symbian\8.1a\S60_2nd_FP3\Epoc32\winscw\c\system\libs

    About usage of that module, I tried this snippet at http://snippets.dzone.com/posts/show/833#related. However, it didn't run without modification. So I did a modification and below is the code which I modified to.

    Code:
    from akntextutils import wrap_text_to_array
    import e32, appuifw
    
    appuifw.app.title = u"Text Wrapper"
    appuifw.app.body = canvas = appuifw.Canvas()
    
    long_str = u"iLorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore..."
    lines = wrap_text_to_array(long_str, 'dense', 176)
    
    #canvas.clear()
    x, y = 2, 0
    for line in lines:
    	y += 15
    	canvas.text((x, y), line, font='dense')
       
    app_lock=e32.Ao_lock()
    app_lock.wait()

Similar Threads

  1. Carbide.J 1.5 Vista Install Problem
    By Jimmmeh in forum Mobile Java Tools & SDKs
    Replies: 12
    Last Post: 2008-01-07, 10:32
  2. Carbide.j 1.5 and Netbeans 5.5 beta 2
    By ovjo12 in forum Mobile Java Tools & SDKs
    Replies: 5
    Last Post: 2007-06-11, 05:43
  3. Install, Install, Install :(
    By rolecram in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2007-02-08, 02:02
  4. Notification on completion of sis file install
    By cesparey in forum Symbian
    Replies: 1
    Last Post: 2006-03-14, 00:49
  5. install error in simulator
    By billqu in forum Symbian
    Replies: 4
    Last Post: 2004-10-29, 13:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×