×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1
    Registered User
    Join Date
    Jan 2008
    Posts
    3

    Unhappy The SDK could not locate a JRE

    I'm using java version 1.6.0_04
    I installed Series 40 5th Edition SDK, Feature Pack 1
    When I start the emulator I got message about missing MSVCR71.dll
    After that I get message: "The SDK could not locate a Java Runtime Environment. You must install JRE 5 to tun this SDK."
    I can't run the emulator.

  2. #2
    Nokia Developer Expert
    Join Date
    Aug 2007
    Posts
    1,595

    Re: The SDK could not locate a JRE

    Hello tccteam,

    have you tried with JRE 5 to see whether it makes the difference?


    Regards,
    r2j7

  3. #3
    Registered User
    Join Date
    Sep 2008
    Posts
    1

    Re: The SDK could not locate a JRE

    Just add c:\program Files\Java\jre1.6.0_04\bin to the %PATH% environment variable

  4. #4
    Registered User
    Join Date
    Jul 2008
    Posts
    12

    Re: The SDK could not locate a JRE

    I'm using netBeans to emulate my Nokia 6212 model and is encountering the same error as well. I've tried artem's idea as well, but it still shows the same error message when I try adding a new java midp platform. Any more suggestions?

  5. #5
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Thumbs up Re: The SDK could not locate a JRE

    Hi Guyes,
    Please note that first you have to install the JRE then your IDE. Netbeans I have seen that it takes automatically the JRE path..and you need not to set it..

    Please start installation from scratch.First install the mobility pack then JDK and then netbeans IDE..every thing will be OK.

    Hope this helps..
    Thanks,
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

  6. #6
    Registered User
    Join Date
    Feb 2006
    Location
    Argentina
    Posts
    6

    Re: The SDK could not locate a JRE

    I am having the same problem, simply installed Series_40_6th_Edition_SDK_v0_9_en, that goes for S40 dp2...

    when trying to run it a window shows saying it couldn't locate JRE 5, nevertheless documentation says JRE should be 6.

    I've tried changing the PATH and JAVA_HOME system variables and also javasoft registry entries, to both JRE 5 (1.5.0.06) and JRE 6 (1.6.0.06) and always the same: SDK could not locate JRE 5 and does not run.

    I am running it on a Windows XP Professional SP 3.

  7. #7
    Registered User
    Join Date
    May 2009
    Posts
    11

    Re: The SDK could not locate a JRE

    i know it is an ald thread that i'm digging up here but i have that error too.
    I have been trying everything: copatibility mode, administrator, using JRE 5 instead of 6 but nothing seems to solve the problem.
    Also i have installed the JDK first followed by the Nokia series 40 NFC SDK and netbeans (in my case) last.

    Any help about solving this problem is more then welcome

  8. #8
    Registered User
    Join Date
    Sep 2008
    Posts
    19

    Unhappy Re: The SDK could not locate a JRE

    Having the same problem. So there is no solution for this, as I see?

  9. #9
    Registered User
    Join Date
    May 2009
    Posts
    11

    Re: The SDK could not locate a JRE

    I have been able to avoid the prob.
    First of all i am working on windows 7 so what i did was:

    • Make sure to have the latest version of your bios
    • Go to your bios and enable virtual machines there
    • Start windows and download the microsoft update that contains "virtual xp mode" for windows 7
    • Install netbeans and the SDK('s) in the virtual xp

    that made it work for me.

    I never had the problem with vista so i guessed it has something to do with the operating system as the NFC SDK was made for windows xp.
    So if you are having trouble with getting the SDK to work properly, just make sure you have a virtual xp to run it in.

    I hope this helps

  10. #10
    Registered User
    Join Date
    Sep 2008
    Posts
    19

    Re: The SDK could not locate a JRE

    I have reinstalled everything and also manually added JRE/bin folder to the PATH environment variable and JDK folder as a JAVA_HOME environment variable, and it worked.

  11. #11
    Registered User
    Join Date
    Oct 2009
    Posts
    1

    Re: The SDK could not locate a JRE

    Solution:

    Add to environment varibale user and system:
    Variable = JAVA_HOME
    Value=C:\Program Files\Java\jre6\bin or your JRE PATH

    Restart and ready

    SO: XP SP3 professional edition

    Saludos espero que les sea util

  12. #12
    Registered User
    Join Date
    Aug 2009
    Posts
    173

    Re: The SDK could not locate a JRE

    About java me installation environment :
    (No mentions included here of the missing dll, about perl, about audio drivers, about file update... when installing java me tools)

    Yes. At a present time, it is very difficult to know, how previous versions of nokia sdk's, sun's jre, jdk's are handled by at the present time tools.
    As far as i have inspected the java jre/jdk vs. ide tools installation "battle" against to the Nokia emulators, i am sure, that any tools based on java 1.6 will be
    installed on any windows correct way (with Eclipse Pulsar, Netbeans 6.9, Nokia later emulators).

    There are so many old discussion of old tooling still going on the discussion pages. But when working with jdk1.6\jre1.6 environment, the tools like (Eclipse, Netbeans, Nokia SDK's after s60 3rd ed fp1) have taken into a account, that, java informs of it's installation environment by Window's registry to these tools.

    Just check : Control Panel > Java icon, how java has spreaded on your computer.
    Just check : HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft

    JAVA_HOME and paths to jre and jdk has gone on to the history pages.

    But the old one of Nokia emulators still stay on their mysterious way going on
    with java environment batlle between computer configurations.
    Last edited by teknikko; 2010-07-15 at 22:58.

  13. #13
    Registered User
    Join Date
    Jan 2011
    Posts
    1

    Re: The SDK could not locate a JRE

    "Add the C:\Program Files\Java\jre6\bin to the path variable". It worked for me. Windows 7.

  14. #14
    Registered User
    Join Date
    Mar 2011
    Posts
    1

    Re: The SDK could not locate a JRE

    worked for me too! (adding C:\Program Files\Java\jre6\bin to the PATH variable)

  15. #15
    Registered User
    Join Date
    Aug 2007
    Posts
    4

    Re: The SDK could not locate a JRE

    Please note all!

    Your JRE folder must be c:\Program Files\Java\jre6 -- if your JRE is in a folder such as jre1.6.0_22 then you need to copy that folder and rename it to jre6 before it will work!

    Ridiculous, please sort this Nokia.

Similar Threads

  1. MIDP applicatyion accessing a servlet not working in series 60 emulator
    By ferozekadamapuzha in forum Mobile Java General
    Replies: 11
    Last Post: 2008-05-07, 18:04
  2. Replies: 1
    Last Post: 2007-04-27, 13:29
  3. Building with another SDK in Carbide
    By fredgauchet in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-03-02, 11:29
  4. Installing the SDK with Borland C++Builder
    By hrajalin in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2003-10-31, 02:46
  5. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×