×

Discussion Board

Results 1 to 15 of 15
  1. #1
    Registered User
    Join Date
    Dec 2007
    Posts
    9

    need newer version of misty

    Hi Cyke64,

    I need newer version of misty (because the current version of misty {http://cyke64.googlepages.com/misty193_selfsigned.sisx } has an "Expired certificate" error

    Please help

    Manu

  2. #2
    Registered User
    Join Date
    Feb 2005
    Location
    Belgium (Europe)
    Posts
    1,352

    Re: need newer version of misty

    Quote Originally Posted by bk_manu View Post
    Hi Cyke64,

    I need newer version of misty (because the current version of misty {http://cyke64.googlepages.com/misty193_selfsigned.sisx } has an "Expired certificate" error

    Please help

    Manu

    Workaround : sign the expired file again with a valid selfsigned cert or change back phone date and install expired file.


    BR
    Cyke64
    pys60 1.4.5 and 2.0.0, pygame, PyS60 CE on E90 and 5800 !

    Find my pys60 extension modules on cyke64.googlepages.com

  3. #3
    Registered User
    Join Date
    Dec 2007
    Posts
    9

    Re: need newer version of misty

    hi cyke,

    sorry I might be a little ignorant, but can u tell me how to self-sign this.

    I have a cert and key file for my device, but it will not work on other devices rght??

    sorry again for being ignorant

    Manu

  4. #4
    Registered User
    Join Date
    Feb 2005
    Location
    Belgium (Europe)
    Posts
    1,352

    Re: need newer version of misty

    Quote Originally Posted by bk_manu View Post
    hi cyke,

    sorry I might be a little ignorant, but can u tell me how to self-sign this.

    I have a cert and key file for my device, but it will not work on other devices rght??

    sorry again for being ignorant

    Manu
    1) Download Mobile Signer by Leftup

    2) Extract contents. You should have the .SIS file (application) and a .KEY file (generic key file).

    3) Install the application to your phone.

    4) With your phone plugged in in Mass Storage (or Data Transfer) mode, access your memory card and create a directory in the root, call it 'Cert' if you like.

    5) Place your .CER file, and the inculded .KEY file into the 'Cert' directory on your memory card.

    6) Now, you can either create another directory in the root, for example 'Install' and place your UNSIGNED .SIS files in here, or just put the UNSIGNED .SIS files in the same 'Cert' directory, its really up to you.

    7) Now disconnect your phone and launch the MobileSigner application on your phone.

    8) Click on 'Sis File:' and browse to the 'Install' directory on your memory card that you created in step 6 (or the location where you put the .SIS file). Locate the .SIS file you want to sign.

    9) Now click on 'Key File' and browse to the 'Cert' directory on your memory card that you created in step 4 (the directory with your .CER and .KEY files). Locate the .KEY file.

    10) Now click on 'Cert File' and repeat the same process as in step 9 (but this time you want to select the .CER file.

    11) Finally, click on 'Password' and enter your own password which would have been used to create the .KEY file.

    12) Now click 'Options' and select 'Save Config'.

    13) Lastly, click 'Options' and select 'SelfSign'.


    Alternatively for signing unsigned sis file with your dev cert you can use the other option and select 'Sign'.

    Now use either the built in File Manager application that comes standard on the N95 or another third party one of your choice, browse to the 'Install' directory and you'll notice two files. One will end .SIS the other will end .SISX. You can easily find out by checking the file's properties, which is which, as the standard File Manager truncates the file names. Just click options > view details. The one ending .SISX is the signed one. Open it and enjoy installing your misty signed module .

    source : logan from n95user.com

    Happy pythoning

    BR
    Cyke64
    pys60 1.4.5 and 2.0.0, pygame, PyS60 CE on E90 and 5800 !

    Find my pys60 extension modules on cyke64.googlepages.com

  5. #5
    Super Contributor
    Join Date
    May 2004
    Location
    Tampere, Finland
    Posts
    524

    Re: need newer version of misty

    Quote Originally Posted by cyke64 View Post
    ... Instructions to build a spaceship ...
    Whoah! Looks kind of complicated... You can also borrow Ensymble's self-signed certificate, which stays valid for 30-some years:

    Code:
    > ensymble.py signsis misty193_selfsigned.sisx
    ensymble.py: warning: no certificate given, using insecure built-in one
    ensymble.py: warning: removing old signatures from input SIS file
    >

  6. #6
    Registered User
    Join Date
    Feb 2005
    Location
    Belgium (Europe)
    Posts
    1,352

    Re: need newer version of misty

    Quote Originally Posted by jethro.fn View Post
    Whoah! Looks kind of complicated... You can also borrow Ensymble's self-signed certificate, which stays valid for 30-some years:

    Code:
    > ensymble.py signsis misty193_selfsigned.sisx
    ensymble.py: warning: no certificate given, using insecure built-in one
    ensymble.py: warning: removing old signatures from input SIS file
    >
    Sometimes it's good to construct a spaceship
    This app can easy sign an unsigned module with your own dev cert or sign your selfsigned module directly on your phone without computer
    I know that ensymble is an funtastic tool for all PyS60 developpers !

    BR
    Cyke64
    pys60 1.4.5 and 2.0.0, pygame, PyS60 CE on E90 and 5800 !

    Find my pys60 extension modules on cyke64.googlepages.com

  7. #7
    Registered User
    Join Date
    Dec 2007
    Posts
    9

    Re: need newer version of misty

    @jethro:

    I already tried that, but misty is having some device capabilities which you will not obtain just with ensymble default certificate (I hope am not wrong Cyke !! )

    @Cyke

    Those really were instructions to build a spaceship

    Trying those rght now will let you know how it goes

    Manu

  8. #8
    Registered User
    Join Date
    Dec 2007
    Posts
    9

    Re: need newer version of misty

    Hey Cyke

    Am still getting an error "Required application access not granted"

    do I need to specify any special capabilities ??


    I tried signing with ensymble also..am getting the same result

    please help

    Manu

  9. #9
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,800

    Re: need newer version of misty

    jethro.fn : Whoah! Looks kind of complicated...
    Hi Jussi,

    I have been using the mobile signer for the past one and a half month (Got it on Christmas )
    Its not complicated at all (once you get used to it). Infact its an easy way to sign the file without using the computer! So I use it when I am not on the computer and use ensymble when I am working on the computer
    The only thing I dont like about the Mobile Signer is that it creates the same name for the signed file as well (expect the extension sisx). But the file size tell the story for who is who!

    Best Regards
    Croozeus
    Pankaj Nathani
    www.croozeus.com

  10. #10
    Registered User
    Join Date
    Dec 2007
    Posts
    9

    Re: need newer version of misty

    Cyke,

    have any updates on my issue

    I am having trouble installing the misty module

    Please help

    Manu

  11. #11
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,800

    Re: need newer version of misty

    Hi Manu,

    I think Cyke gave you the solotion in his 1st post!

    Workaround : sign the expired file again with a valid selfsigned cert or change back phone date and install expired file.
    You can use the mobile signer or ensymble for signing the sis file.

    Best Regards
    Croozeus
    Pankaj Nathani
    www.croozeus.com

  12. #12
    Registered User
    Join Date
    Dec 2007
    Posts
    9

    Re: need newer version of misty

    Croozeus,

    I think you dint read my previous posts

    I tried both the ensymble and mobile signer to self sign misty module but had no success. Yeah turning back the time to 2007 works, but its a pain.

    Thats why I asked Cyke what capabilities he used to self-sign the module, because I guess if i self sign with the same capabilities, maybe I wont get the "Required application access not granted" error.

    any workarounds??

    Manu

  13. #13
    Registered User
    Join Date
    Dec 2007
    Posts
    9

    Re: need newer version of misty

    Cyke,

    Any updates ??

    Manu

  14. #14
    Regular Contributor
    Join Date
    Aug 2008
    Location
    Ahmedabad,Gujarat,India
    Posts
    65

    Re: need newer version of misty

    I want to install misty module on emulator.

    I have tried to sign this sis with ensymble using 0000...00 imei.

    But not able to install on emulator. it gives error "requested application is not granted"

    It will be fine if i could have misty sdk files so that i can directly paste into emulator directory.(Same as appswitch)

    If this could done it will be great for us.
    Thanks and Regards,
    Niraj Pendal

  15. #15
    Regular Contributor
    Join Date
    Aug 2008
    Location
    Ahmedabad,Gujarat,India
    Posts
    65

    Re: need newer version of misty

    I have tried simplesis to get files from sis but it will not help me.
    Last edited by nirajpendal; 2008-09-10 at 13:30. Reason: Posted in wrong place... sorry...
    Thanks and Regards,
    Niraj Pendal

Similar Threads

  1. Porting C Open source.
    By debasish1234 in forum Open C/C++
    Replies: 7
    Last Post: 2008-01-28, 11:06
  2. updating Symbian Signed application with a newer version
    By minstn in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 7
    Last Post: 2007-04-12, 11:33
  3. Replies: 0
    Last Post: 2007-04-03, 10:58
  4. SDK Installation problems (wrong drive) S60 3rd
    By Jeepy in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2007-03-12, 21:59
  5. nokia 7210 modem via IR doesn't work !
    By oussamaaiadi in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2003-03-06, 10:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×