×

Discussion Board

Results 1 to 6 of 6

Thread: carbide-error

  1. #1
    Registered User
    Join Date
    Jan 2008
    Posts
    5

    carbide-error

    sub:No rule to make target error

    i am using carbide c++ 1.2.
    whnever i am trying to build a project on any of the s60 versions its giving no rule to make target error.
    in the case of uiq its working fine.
    i also tried the solution that provided in this link http://wiki.forum.nokia.com/index.ph...nd_line_errors
    but still the error is coming .pls help

    thax in advance

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: carbide-error

    Quote Originally Posted by upendersolanki View Post
    sub:No rule to make target error

    i am using carbide c++ 1.2.
    whnever i am trying to build a project on any of the s60 versions its giving no rule to make target error.
    in the case of uiq its working fine.
    i also tried the solution that provided in this link http://wiki.forum.nokia.com/index.ph...nd_line_errors
    but still the error is coming .pls help

    thax in advance
    Welcome to the Forum!!
    Check by typing 'devices' in the command prompt if your intended SDK is set to default. you could try 'abld build winscw udeb' and see if it starts compiling.

    Also more information regarding the installation of SDK, perl version etc can be helpful in understanding where the problem could possibly be.

  3. #3
    Registered User
    Join Date
    Sep 2006
    Posts
    35

    Re: carbide-error

    Hi Upender ,

    Please see to it that you have installed all the allied softwares like Carbide, Perl, SDK on the same drive.

    Also use Active Perl v 5.6.1 build 635 for more optimal working with Symbian build commands.

    These two are major reasons for this error to occur.Let me know if the problem appears even after the above precautions are taken.

    With Regards,
    Ravikiran

  4. #4
    Registered User
    Join Date
    Feb 2008
    Posts
    15

    Re: carbide-error

    Hi,
    i have one 2 error,one of them is replied in your site,another is:
    Error 10 error CBDERR: Deleting the corrupted output. C:\Symbian\8.0a\S60_2nd_FP2_CW\\Epoc32\release\winscw\udeb\Symbian1Client.exe
    i am using carbidevs.3.
    please help me to solve it.

  5. #5
    Registered User
    Join Date
    Feb 2008
    Posts
    1

    Re: carbide-error

    Hi i have some problems when starting carbide.c++ under MicroSoft win vista
    It shows me the loading screen then :
    "An error has occured , see the log file ..."
    !SESSION 2008-02-05 20:54:26.796 -----------------------------------------------
    eclipse.buildId=M20060921-0945
    java.version=1.5.0_05
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
    Command-line arguments: -os win32 -ws win32 -arch x86

    !ENTRY org.eclipse.osgi 4 0 2008-02-05 20:54:27.581
    !MESSAGE Application error
    !STACK 1
    java.lang.UnsatisfiedLinkError: no swt-win32-3235 in java.library.path
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.loadLibrary(Unknown Source)
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
    at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
    at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125)
    at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:433)
    at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
    at org.eclipse.ui.internal.ide.IDEApplication.createDisplay(IDEApplication.java:122)
    at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:75)
    at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
    at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
    at org.eclipse.core.launcher.Main.run(Main.java:977)
    at org.eclipse.core.launcher.Main.main(Main.java:952)

    !ENTRY org.eclipse.osgi 2 0 2008-02-05 20:54:27.653
    !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.653
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codeg...0609210005.jar was not resolved.
    !SUBENTRY 2 org.eclipse.emf.codegen.ecore.ui 2 0 2008-02-05 20:54:27.653
    !MESSAGE Missing required bundle org.eclipse.jdt.core_[3.2.0,4.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.654
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codeg...0609210005.jar was not resolved.
    !SUBENTRY 2 org.eclipse.emf.codegen.ecore 2 0 2008-02-05 20:54:27.654
    !MESSAGE Missing required bundle org.eclipse.jdt.launching_[3.2.0,4.0.0).
    !SUBENTRY 2 org.eclipse.emf.codegen.ecore 2 0 2008-02-05 20:54:27.654
    !MESSAGE Missing required bundle org.eclipse.jdt.core_[3.2.0,4.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.654
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codeg...0609210005.jar was not resolved.
    !SUBENTRY 2 org.eclipse.emf.codegen.ui 2 0 2008-02-05 20:54:27.654
    !MESSAGE Missing required bundle org.eclipse.jdt.core_[3.2.0,4.0.0).
    !SUBENTRY 2 org.eclipse.emf.codegen.ui 2 0 2008-02-05 20:54:27.654
    !MESSAGE Missing required bundle org.eclipse.jdt.launching_[3.2.0,4.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.654
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codeg...0609210005.jar was not resolved.
    !SUBENTRY 2 org.eclipse.emf.codegen 2 0 2008-02-05 20:54:27.654
    !MESSAGE Missing required bundle org.eclipse.jdt.launching_[3.2.0,4.0.0).
    !SUBENTRY 2 org.eclipse.emf.codegen 2 0 2008-02-05 20:54:27.654
    !MESSAGE Missing required bundle org.eclipse.jdt.core_[3.2.0,4.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.654
    !MESSAGE Bundle update@plugins/org.eclipse.emf.impor...0609210005.jar was not resolved.
    !SUBENTRY 2 org.eclipse.emf.importer.java 2 0 2008-02-05 20:54:27.654
    !MESSAGE Missing required bundle org.eclipse.jdt.core_[3.2.0,4.0.0).

    !ENTRY org.eclipse.osgi 2 0 2008-02-05 20:54:27.660
    !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.660
    !MESSAGE Bundle update@plugins/org.eclipse.emf.ant_2...0609210005.jar [109] was not resolved.
    !SUBENTRY 2 org.eclipse.emf.ant 2 0 2008-02-05 20:54:27.660
    !MESSAGE Missing required bundle org.eclipse.emf.codegen_[2.2.1,3.0.0).
    !SUBENTRY 2 org.eclipse.emf.ant 2 0 2008-02-05 20:54:27.660
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore_[2.2.1,3.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.660
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codeg...0609210005.jar [110] was not resolved.
    !SUBENTRY 2 org.eclipse.emf.codegen.ecore.ui 2 0 2008-02-05 20:54:27.660
    !MESSAGE Missing required bundle org.eclipse.jdt.core_[3.2.0,4.0.0).
    !SUBENTRY 2 org.eclipse.emf.codegen.ecore.ui 2 0 2008-02-05 20:54:27.660
    !MESSAGE Missing required bundle org.eclipse.emf.codegen.ecore_[2.2.1,3.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.660
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codeg...0609210005.jar [111] was not resolved.
    !SUBENTRY 2 org.eclipse.emf.codegen.ecore 2 0 2008-02-05 20:54:27.660
    !MESSAGE Missing required bundle org.eclipse.jdt.core_[3.2.0,4.0.0).
    !SUBENTRY 2 org.eclipse.emf.codegen.ecore 2 0 2008-02-05 20:54:27.660
    !MESSAGE Missing required bundle org.eclipse.jdt.launching_[3.2.0,4.0.0).
    !SUBENTRY 2 org.eclipse.emf.codegen.ecore 2 0 2008-02-05 20:54:27.660
    !MESSAGE Missing required bundle org.eclipse.emf.codegen_[2.2.1,3.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.660
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codeg...0609210005.jar [112] was not resolved.
    !SUBENTRY 2 org.eclipse.emf.codegen.ui 2 0 2008-02-05 20:54:27.660
    !MESSAGE Missing required bundle org.eclipse.emf.codegen_[2.2.1,3.0.0).
    !SUBENTRY 2 org.eclipse.emf.codegen.ui 2 0 2008-02-05 20:54:27.660
    !MESSAGE Missing required bundle org.eclipse.jdt.core_[3.2.0,4.0.0).
    !SUBENTRY 2 org.eclipse.emf.codegen.ui 2 0 2008-02-05 20:54:27.660
    !MESSAGE Missing required bundle org.eclipse.jdt.launching_[3.2.0,4.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.660
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codeg...0609210005.jar [113] was not resolved.
    !SUBENTRY 2 org.eclipse.emf.codegen 2 0 2008-02-05 20:54:27.660
    !MESSAGE Missing required bundle org.eclipse.jdt.core_[3.2.0,4.0.0).
    !SUBENTRY 2 org.eclipse.emf.codegen 2 0 2008-02-05 20:54:27.661
    !MESSAGE Missing required bundle org.eclipse.jdt.launching_[3.2.0,4.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.661
    !MESSAGE Bundle update@plugins/org.eclipse.emf.conve...0609210005.jar [117] was not resolved.
    !SUBENTRY 2 org.eclipse.emf.converter 2 0 2008-02-05 20:54:27.661
    !MESSAGE Missing required bundle org.eclipse.emf.codegen.ecore_[2.2.1,3.0.0).
    !SUBENTRY 2 org.eclipse.emf.converter 2 0 2008-02-05 20:54:27.661
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore.ui_[2.2.1,3.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.661
    !MESSAGE Bundle update@plugins/org.eclipse.emf.ecore...0609210005.jar [122] was not resolved.
    !SUBENTRY 2 org.eclipse.emf.ecore.sdo.editor 2 0 2008-02-05 20:54:27.661
    !MESSAGE Missing required bundle org.eclipse.emf.codegen.ecore_[2.2.1,3.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.661
    !MESSAGE Bundle update@plugins/org.eclipse.emf.expor...0609210005.jar [129] was not resolved.
    !SUBENTRY 2 org.eclipse.emf.exporter 2 0 2008-02-05 20:54:27.661
    !MESSAGE Missing required bundle org.eclipse.emf.converter_[2.2.1,3.0.0).
    !SUBENTRY 2 org.eclipse.emf.exporter 2 0 2008-02-05 20:54:27.661
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore.ui_[2.2.1,3.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.661
    !MESSAGE Bundle update@plugins/org.eclipse.emf.impor...0609210005.jar [130] was not resolved.
    !SUBENTRY 2 org.eclipse.emf.importer.ecore 2 0 2008-02-05 20:54:27.662
    !MESSAGE Missing required bundle org.eclipse.emf.importer_[2.2.1,3.0.0).
    !SUBENTRY 2 org.eclipse.emf.importer.ecore 2 0 2008-02-05 20:54:27.662
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore.ui_[2.2.1,3.0.0).
    !SUBENTRY 2 org.eclipse.emf.importer.ecore 2 0 2008-02-05 20:54:27.662
    !MESSAGE Missing optionally required bundle org.eclipse.emf.ant_[2.2.0,3.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.662
    !MESSAGE Bundle update@plugins/org.eclipse.emf.impor...0609210005.jar [131] was not resolved.
    !SUBENTRY 2 org.eclipse.emf.importer.java 2 0 2008-02-05 20:54:27.662
    !MESSAGE Missing required bundle org.eclipse.jdt.core_[3.2.0,4.0.0).
    !SUBENTRY 2 org.eclipse.emf.importer.java 2 0 2008-02-05 20:54:27.662
    !MESSAGE Missing required bundle org.eclipse.emf.importer_[2.2.1,3.0.0).
    !SUBENTRY 2 org.eclipse.emf.importer.java 2 0 2008-02-05 20:54:27.662
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore.ui_[2.2.1,3.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-02-05 20:54:27.662
    !MESSAGE Bundle update@plugins/org.eclipse.emf.impor...0609210005.jar [132] was not resolved.
    !SUBENTRY 2 org.eclipse.emf.importer.rose 2 0 2008-02-05 20:54:27.662
    !MESSAGE Missing required bundle org.eclipse.emf.importer_[2.2.1,3.0.0).

    etc..
    Can you help me please ?
    mail

  6. #6
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: carbide-error

    Quote Originally Posted by DarkPrisoner3 View Post
    Hi i have some problems when starting carbide.c++ under MicroSoft win vista
    It shows me the loading screen then :
    "An error has occured , see the log file ..."


    Can you help me please ?
    mail
    Please start a new thread especially if you are not having exactly the same problem.

    Well have you done whats explained here for the Vista ?
    Maybe it might help

Similar Threads

  1. XMl Parser Implementation for Symbian
    By ittiam in forum Symbian
    Replies: 26
    Last Post: 2009-09-16, 05:26
  2. Error with makesis.exe and creating the .pkg file
    By gramya87 in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2007-10-10, 13:53
  3. Help with lnk2019 lnk1120 error
    By yuenfatt in forum Symbian
    Replies: 8
    Last Post: 2007-08-24, 08:21
  4. S60 2nd to 3rd/ PlatformSecurity / Capabilities
    By jarkoos in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 4
    Last Post: 2007-04-14, 14:08
  5. User break point error in Grid
    By ag24master in forum Symbian User Interface
    Replies: 0
    Last Post: 2003-08-07, 08:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×