×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Dec 2007
    Posts
    42

    Red face problem in using py2sis tool for sdk 3.0

    hi,

    I tried making a standalone application using py2sis tool provided in standard 1.4.1 sdk available on sourceforge. I ran the command

    >> python py2sis.py snake.py snake.sis --uid=0x0fffffff --appname=snakegame --sdk30

    and the output was ...

    Creating SIS for SDK3.0 and later
    Processing template C:\Symbian\9.2\S60_3rd_FP1\Epoc32\tools\py2sis\build\Icons_aif.mk.template
    Processing template C:\Symbian\9.2\S60_3rd_FP1\Epoc32\tools\py2sis\build\PyTest.cpp.template
    Processing template C:\Symbian\9.2\S60_3rd_FP1\Epoc32\tools\py2sis\build\PyTest.rss.template
    Processing template C:\Symbian\9.2\S60_3rd_FP1\Epoc32\tools\py2sis\build\PyTest_reg.rss.template
    Processing template C:\Symbian\9.2\S60_3rd_FP1\Epoc32\tools\py2sis\build\app.mmp.template
    Compiling...
    Done.
    ERROR [Errno 2] No such file or directory: '\\Epoc32\\release\\GCCE\\UREL\\snakegame_0x0fffffff.exe'

    and when i used the same command with --autostart
    >> python py2sis.py snake.py snake.sis --uid=0x0fffffff --appname=snakegame --sdk30 --autostart

    output is

    Creating SIS for SDK3.0 and later
    Processing template C:\Symbian\9.2\S60_3rd_FP1\Epoc32\tools\py2sis\build\Icons_aif.mk.template
    Processing template C:\Symbian\9.2\S60_3rd_FP1\Epoc32\tools\py2sis\build\PyTest.cpp.template
    Processing template C:\Symbian\9.2\S60_3rd_FP1\Epoc32\tools\py2sis\build\PyTest.rss.template
    Processing template C:\Symbian\9.2\S60_3rd_FP1\Epoc32\tools\py2sis\build\PyTest_reg.rss.template
    Processing template C:\Symbian\9.2\S60_3rd_FP1\Epoc32\tools\py2sis\build\app.mmp.template
    ERROR [Errno 2] No such file or directory: '00000000.rss'


    clueless . any help is greatly appreciated , thanx.

  2. #2
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: problem in using py2sis tool for sdk 3.0

    I can't help you with that exact problem, but I warmly recommend you use ensymble as it is more straightforward and easy to use.

  3. #3
    Registered User
    Join Date
    Dec 2007
    Posts
    42

    Re: problem in using py2sis tool for sdk 3.0

    Quote Originally Posted by bogdan.galiceanu View Post
    I can't help you with that exact problem, but I warmly recommend you use ensymble as it is more straightforward and easy to use.
    hey i jus want to use the autostart feature in 1.4.1 for 3rd edition, do we have such a thing in ensymble ??

  4. #4
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: problem in using py2sis tool for sdk 3.0

    Yes, there's the --autostart option.

  5. #5
    Registered User
    Join Date
    Dec 2007
    Posts
    42

    Re: problem in using py2sis tool for sdk 3.0

    hey thanx bogdan.galiceanu !!!
    i successfully made the sis file but i am not able to install it on my phone [E62]. The error says "Unable to install a protected application from an untrusted supplier" . Guess it's something to do with signing the application, which i never did could you please help me out once again .

  6. #6
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,795

    Re: problem in using py2sis tool for sdk 3.0

    Hi smilesnigam,

    I guess you are trying to install the unsigned application.
    Go to Tools->Application Manager->Settings->Software Installation and choose All.
    Then try installing the application.

    Hope that helps.

    Best Regards
    Croozeus
    Last edited by croozeus; 2008-01-31 at 09:14. Reason: corrected Typo
    Pankaj Nathani
    www.croozeus.com

  7. #7
    Registered User
    Join Date
    Dec 2007
    Posts
    42

    Re: problem in using py2sis tool for sdk 3.0

    Hey croozeus, i tried that too but no use .

  8. #8
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: problem in using py2sis tool for sdk 3.0

    In case you haven't read it, here's the documentation. And the tool.

    I'm not very good at explaining the signing process, but I can recommend this guide. You should try this before you read that long documentation.

    Feel free to ask if you have any more questions

  9. #9
    Super Contributor
    Join Date
    May 2004
    Location
    Tampere, Finland
    Posts
    524

    Re: problem in using py2sis tool for sdk 3.0

    Quote Originally Posted by smilesnigam View Post
    "Unable to install a protected application from an untrusted supplier"
    This error message simply means you're using an invalid UID. Are you using an UID meant for 2nd Edition devices? You need to get an UID compatible with 3rd Edition devices from www.symbiansigned.com, or let Ensymble pick a temporary one automatically.

  10. #10
    Registered User
    Join Date
    Dec 2007
    Posts
    42

    Re: problem in using py2sis tool for sdk 3.0

    Quote Originally Posted by jethro.fn View Post
    This error message simply means you're using an invalid UID. Are you using an UID meant for 2nd Edition devices? You need to get an UID compatible with 3rd Edition devices from www.symbiansigned.com, or let Ensymble pick a temporary one automatically.
    hey thanx jethro.fn, i successfully installed the application but the app doesnt seems to act at startups even though i have used --autostart while making the sis file. i used ensymble to make the sis files

    btw ne idea why symbian py2sis tool isnt working, the problem which started this thread. thnx for all the help guys.

  11. #11
    Super Contributor
    Join Date
    May 2004
    Location
    Tampere, Finland
    Posts
    524

    Re: problem in using py2sis tool for sdk 3.0

    Quote Originally Posted by smilesnigam View Post
    hey thanx jethro.fn, i successfully installed the application but the app doesnt seems to act at startups even though i have used --autostart while making the sis file. i used ensymble to make the sis files
    I forgot to mention this earlier... To use the --autostart option, you need to obtain a developer certificate and an UID from the protected range from www.symbiansigned.com. Phones refuse to start self-signed applications. This is what Ensymble README has to say:
    Note: Self-signed applications and applications with UID in the
    unprotected range cannot register to be automatically started (see
    options "--uid" and "--cert" above).
    Quote Originally Posted by smilesnigam View Post
    btw ne idea why symbian py2sis tool isnt working, the problem which started this thread.
    No idea. I've never used it.

Similar Threads

  1. S60 - Device Connecitivity Tool - N95 USB connection problem
    By SurfingPop in forum PC Suite API and PC Connectivity SDK
    Replies: 9
    Last Post: 2010-06-18, 19:56
  2. carbide vs 3.0 problem
    By vickey in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2009-01-02, 07:20
  3. Carbide.VS 3.0 miflist compilation problem
    By vipako in forum Symbian Tools & SDKs
    Replies: 12
    Last Post: 2008-05-05, 07:59
  4. Compilation of rss freezes in Carbide.vs 3.0 - problem found
    By omahlama in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2008-01-16, 19:46
  5. Replies: 1
    Last Post: 2007-11-28, 11:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×