×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Dec 2006
    Posts
    30

    Recording audio problem 5300

    OK all I want to do is to record some audio on a 5300...

    Code:
    public void recordAudio() throws Exception {
    		// new Thread(this).start();
    		Utils.debugOut("starting...Player ");
    
    		// Following line gives error "encoding amr not supported ???"
    		// player_ = Manager.createPlayer("capture://audio?encoding=amr");
    		player_ = Manager.createPlayer("capture://audio");
    
    		player_.addPlayerListener(this);
    		player_.realize();
    
    		RecordControl rc = getRecordControl();
    		if (rc != null) {
    			String path = "file:///E:/test.amr";
    			fc = (FileConnection) Connector.open(path, Connector.READ_WRITE);
                          // do this to get rid of "Do you want to replace e:/test.amr? dialog...(??)
    			if (fc.exists()) {
    				fc.delete();
    			}
    			fc.create();
    			os = fc.openOutputStream();
    			rc.setRecordStream(os);
    			rc.startRecord();
    		}
    
    		player_.start();
    	}
    
    	public void stopRecordAudio() throws Exception {
    		Utils.debugOut("Stopping audio recorder....");
    		RecordControl rc = getRecordControl();
    		if (rc != null) {
    			rc.stopRecord();
    			rc.commit();
    			os.close();
    			fc.close();
    
    			player_.close();
    		}
    	}

    Now this all works but there is an annoying dialog stating "Application access set to not allowed".
    Now the application is signed and everything is set to "always allowed" including "Multimedia Recording", "Read user data" and "Add and edit data".
    The jad also has the following opt params:
    javax.microedition.io.Connector.file.write, javax.microedition.io.Connector.file.read, javax.microedition.media.control.RecordControl

    How do I make this dialog go away??????

    Cheers

    Ed.

  2. #2
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,430

    Re: Recording audio problem 5300

    Does your phone have an operator branded firmware ? Does the app work before Signing ?

    Regards
    Gopal

  3. #3
    Registered User
    Join Date
    Dec 2006
    Posts
    30

    Re: Recording audio problem 5300

    Hi there... I have tested this on one unlocked phone, one O2 locked phone and one Orange locked phone, all running OS 05.51. (all Nokia 5300)

    If the app is not signed I get a pop up stating "Application access set to not allowed" with no icon, and "OK" is displayed above the centre soft button. Nothing gets recorded.

    If the app is signed I get a pop up stating "Application access set to not allowed" with a light green "i"(nfo) icon, I dont have to press anything and it goes away after a second and it records.

    OS bug??

    Thanks for your help.

    Ed.

  4. #4
    Registered User
    Join Date
    Dec 2006
    Posts
    30

    Re: Recording audio problem 5300

    How do I raise this as a bug to Nokia?

    Cheers
    Ed.

  5. #5
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,430

    Re: Recording audio problem 5300

    Am not sure this a bug or not, but since you asked, here is the link

    Report a platform bug
    If you want to report a bug (or a bug solution) privately, click here and follow the "Report a Platform Bug" link in the left-hand navigation bar. This type of bug report will be handled by Forum Nokia experts.

    Please note that if you are not a Forum Nokia Developer Programs member or have not previously registered for access to the Forum Nokia Developer Programs e-store or Technical Support, you will need to register before reporting a bug in that manner.

    You can also report an issue publicly, via the Forum Nokia KnowledgeBase | Developer Contributed portal. This type of report will be available to all members of the community for reviewing and commenting.

    Regards
    Gopal

  6. #6
    Registered User
    Join Date
    Sep 2007
    Posts
    20

    Re: Recording audio problem 5300

    I am facing the same problems with a 6300 and a 5310 here.

    When I sign the midlet the phone shows that error message which disappers after a while and everything works fine.

    If I don't sign it all is OK.

    Did you find a solution?

  7. #7
    Registered User
    Join Date
    Dec 2006
    Posts
    30

    Re: Recording audio problem 5300

    Its a known issue, and one that has not been fixed as far as I can tell....

    KIJ000874

    Cheers

    Ed

  8. #8
    Registered User
    Join Date
    Sep 2007
    Posts
    20

    Re: Recording audio problem 5300

    Thanks Ed it's good to know.

    Savvas

Similar Threads

  1. Recording audio in loop, crashes on N70
    By hsundt in forum Mobile Java Media (Graphics & Sounds)
    Replies: 3
    Last Post: 2010-12-29, 15:22
  2. Low audio recording/playback volume for 5300, 6300 p
    By Phonetechgal in forum Mobile Java General
    Replies: 0
    Last Post: 2007-11-24, 14:40
  3. Please Help Recording mp4 audio.....
    By codsw2 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 0
    Last Post: 2007-10-08, 15:24
  4. Problem with Audio & Thread
    By ecio83 in forum Symbian Media (Closed)
    Replies: 3
    Last Post: 2007-07-16, 16:45
  5. problem recording audio
    By fagiano in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2006-11-24, 15:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •