×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Feb 2008
    Posts
    26

    An error using s60 emulator with eclipse, please help

    Greetings,

    I'm using eclipse with s60FP2nd edition emulator downloaded from here. Whenever I'm compiling and running my program this error shows. I tried running the example helloworld included in the installation files and it still has errors. Can anybody tell me how to solve this problem. thanks

    WARNING: Attribute value for MicroEdition-Profile defined in JAR manifest is not supported.
    Emulator: java.lang.NullPointerException

  2. #2
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,429

    Re: An error using s60 emulator with eclipse, please help

    Hi kikoy87! Welcome to Nokia Developer Discussion Boards!! :)

    As the warning mentioned, Please check what is the MicroEdition-Profile value in the JAD and Manifest file. Is it MIDP-2.0 or MIDP-2.1 . Try changing it to MIDP-2.0

    Regards
    Gopal
    Last edited by balagopalks; 2008-02-01 at 07:56.
    Twitter : @balagopalks
    Linkedin : @balagopalks

  3. #3
    Registered User
    Join Date
    Feb 2008
    Posts
    26

    Re: An error using s60 emulator with eclipse, please help

    Hey thanks Bolagolpaks for replying,

    I took your advice and changed the MIDp value in the jad file to MIDp 2.0, I'm running the program directly from eclipse so I don't know if it has a manifest file but I think the manifest file creation is automatic, anyway there is still an error when I run the program.

    this is what it prints out:

    Emulator: java.lang.NullPointerException

    so I don't really know how to solve this problem, can you advise me on what to do with this?

  4. #4
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,429

    Re: An error using s60 emulator with eclipse, please help

    Quote Originally Posted by kikoy87 View Post
    I took your advice and changed the MIDp value in the jad file to MIDp 2.0
    You changed it from MIDP 2.1 to 2.0 in the JAD ? If so it should also be changed in Manifest file as well. The Manifest file will be inside JAR file. You can change the value before building the MIDlet or can open the JAR file with applications like WinRar and edit the Manifest file, save it. If you are manually editing the JAR fie make sure that MIDlet-Jar-Size: has been changed in the JAD file after modifying the JAR.

    Quote Originally Posted by kikoy87 View Post
    Hey thanks Bolagolpaks for replying
    BTW, you changed the entire spelling of my name! ;)

    Regards
    Gopal

  5. #5
    Registered User
    Join Date
    Feb 2008
    Posts
    26

    Re: An error using s60 emulator with eclipse, please help

    oh sorry about that balagopalks,

    I understand what you are saying about the jad file and manifest file. So the only problem left is:

    Emulator: java.lang.NullPointerException

    whenever I try to run the program on the nokia s60 emulator downloaded from nokia forum (s60 2nd edition full pack 3) that problem shows up and stops running the program.
    I read from other threads that it really is hard to run programs in the s60 emulator. So right now I'm just using wtk from sun.
    But in the near future I'm really gonna need to use the s60 emulator, so can you advise me how to do it? thanks alot for all your help.

  6. #6
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,429

    Re: An error using s60 emulator with eclipse, please help

    As the API docs say, NullPointerException is thrown when an application attempts to use null in a case where an object is required. These include:

    Calling the instance method of a null object.
    Accessing or modifying the field of a null object.
    Taking the length of null as if it were an array.
    Accessing or modifying the slots of null as if it were an array.
    Throwing null as if it were a Throwable value.

    Are you loading any images from the JAR file or accessing the RecordStore ?

    Regards
    Gopal

  7. #7
    Registered User
    Join Date
    Feb 2008
    Posts
    26

    Re: An error using s60 emulator with eclipse, please help

    Nope, I'm running a simple Hello world program included from the installation folder from nokia s60

  8. #8
    Registered User
    Join Date
    Feb 2008
    Posts
    26

    Re: An error using s60 emulator with eclipse, please help

    hey everybody,

    the problem has been solved, I changed the IDE I'm using to Net Beans, and when I ran the program..

    NO ERROR APPEARED! I didn't change any part of the code so I guess the problem was the IDE.

Similar Threads

  1. Problem with S60 Emulator in Eclipse / Carbide.j
    By boris.polania in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2008-08-18, 22:59
  2. CarbideJ 1.5, Eclipse & S60
    By sambo1972 in forum Mobile Java Tools & SDKs
    Replies: 8
    Last Post: 2008-08-07, 08:38
  3. Please HELP. Impossible Eclipse + Carbide.j
    By videador in forum Mobile Java Tools & SDKs
    Replies: 13
    Last Post: 2007-03-22, 06:06
  4. Replies: 5
    Last Post: 2006-04-21, 04:40
  5. Nokia Connectivity Framework , Eclipse and a BT Dongle
    By shriansh in forum Bluetooth Technology
    Replies: 4
    Last Post: 2006-02-15, 19:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×