×

Discussion Board

Results 1 to 3 of 3

Thread: Display Unicode

  1. #1
    Registered User
    Join Date
    Nov 2007
    Posts
    29

    Display Unicode

    Hi,

    I am using s60 3rd ed. fp1 and I want to display unicode character.But I cannot display.

    I read all the thread related to unicode.And i follow all the procedure to use the unicode.

    My code: .RSS file

    Code:
    //  RESOURCE IDENTIFIER
    NAME    AWIZ // 4 letter ID
    
    //  INCLUDES
    
    #include <eikon.rh>
    #include "Symbian1.hrh"
    #include "Symbian1.rls"
    #include <avkon.rsg>
    #include <avkon.rh>
    #include <avkon.mbg>
    #include <appinfo.rh>
    ......
    ........
    
    RESOURCE MENU_PANE r_symbian1_app_menu
        {
        items =
            {
            MENU_ITEM { command = ESymbian1CmdAppTest; txt = qtn_appl_option_item; },
            MENU_ITEM { command = EAknCmdExit; txt = qtn_appl_exit; }
            };
        }
    
    
    RESOURCE TBUF r_label_text {	buf = qtn_label_text; }
    Code: .RLS file
    Code:
    CHARACTER_SET UTF8
    //  LOCALISATION STRINGS
    
    //d:Caption string for app.
    rls_string qtn_app_caption_string "ENG"
    rls_string qtn_app_short_caption_string "English"
    
    //d:Command in options menu.
    //d:Example application spesific command.
    //l:list_single_popup_submenu_pane_1
    //
    rls_string qtn_appl_test "Test"
    
    // menu exit
    rls_string qtn_appl_exit "Exit"
    
    //d:Command in options menu.
    //d:Example application spesific command.
    //l:list_single_popup_submenu_pane_1
    //
    rls_string qtn_appl_option_item "<0x0030><0x0031>"
    
    //d:Command in options menu.
    //d:Example command for view 1.
    //l:list_single_popup_submenu_pane_1
    //
    rls_string qtn_view1_option_item "<0x0030><0x0031>"
    
    rls_string qtn_label_text"<0x0030><0x0031>"
    
    rls_string qtn_app_buf"buf"
    
    // End of File
    I can see only <0x0030><0x0031> in Emulator and in Device
    Where do I mistake?

    Thank You.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: Display Unicode

    Quote Originally Posted by cds.ds View Post
    rls_string qtn_view1_option_item "<0x0030><0x0031>"

    I can see only <0x0030><0x0031> in Emulator and in Device
    Where do I mistake?

    Thank You.
    "<0x0030><0x0031>" is simply a string, that is why you get it as a string. You can try what happens if you remove the "-s (is that coming from an example?)
    You can also try "\x0030\x0031".
    Last edited by wizard_hu_; 2008-02-05 at 09:39.

  3. #3
    Registered User
    Join Date
    Nov 2007
    Posts
    29

    Re: Display Unicode

    Hi,

    Thank You very much.
    Yes you are right.I got my solution.
    When I remove "-string I got the character.

    Thanks again

Similar Threads

  1. Recording in Amr Format
    By losym in forum Symbian Media (Closed)
    Replies: 12
    Last Post: 2009-03-26, 06:41
  2. Nokia N-Series Complete Model Line-Up
    By Dopod in forum General Development Questions
    Replies: 6
    Last Post: 2008-07-22, 20:16
  3. display unicode file in a CEikRichTextEditor
    By papana in forum Symbian User Interface
    Replies: 0
    Last Post: 2006-07-21, 16:02
  4. Replies: 0
    Last Post: 2004-10-07, 08:57
  5. Socket received data converted to unicode doesn't display the full informat
    By prsens in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2003-03-17, 03:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •