×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Feb 2008
    Posts
    4

    Landmark HTTP response

    I have been trying to figure out the proper header for the HTTP landmark object encapsulation, still have not been successful.

    We can't match the proper RFC2616 headers to the code below. Anyone know the proper format. We were successful with email format encapsulation but HTTP is giving us hard time.

    Where can I find more information regarding proper headers? or best file sample. Thanks


    [other RFC2616 headers]

    Content-Type: multipart/mixed; boundary="-- simple boundary"
    Content-Type: text/html; charset=us-ascii
    Content-Length: nnnn
    <html>
    ...some html page...

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2003
    Posts
    4,104
    I do not understand your question. Could you please try again a second time?

    Just guessing:
    Do you want to download a Nokia Landmarks file from a HTTP server?
    AddType application/vnd.nokia.landmarkcollection+xml .lmx
    worked for me in my Apache webserver.
    Last edited by traud; 2008-02-08 at 13:51.

  3. #3
    Registered User
    Join Date
    Feb 2008
    Posts
    4

    Re: Landmark HTTP response

    Yes, that is exactly what I am trying to do and I can't seem to find the right format for the file to be accepted by phone.

    I added the Type, but I think my problem is in the header.

    If it worked for you can you share it? thanks

  4. #4
    Registered User
    Join Date
    Feb 2008
    Posts
    4

    Re: Landmark HTTP response

    I have followed the exchange format, but I am a bit confused and I tried to save file on my server in may different formats .lmx.xml.hmtl, however I can't seem to get the right format of the file for the phone to accept it through the mobile browser as a Landmark. The best I accomplished is saving text to Notes.



    Content-Type: multipart/mixed;
    boundary="boundary"

    --boundary

    Content-Type: text/html; charset=us-ascii
    Content-Length: nnnn
    <html>
    ...some html page...
    </html>

    --boundary

    Content-Type: application/vnd.nokia.landmarkcollection+xml; charset=utf-8
    Content-Length: nnnn

    <?xml version="1.0" encoding="UTF-8"?>
    <lm:lmx xmlns:lm="http://www.nokia.com/schemas/location/landmarks/1/0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.nokia.com/schemas/location/landmarks/1/0/ lmx.xsd">

    <lm:landmarkCollection>
    <lm:landmark>
    <lm:name>The Cambridge Theatre Theatre</lm:name>
    <lm:coordinates>
    <lm:latitude>51.513807</lm:latitude>
    <lm:longitude>-0.126878</lm:longitude>
    </lm:coordinates>
    <lm:addressInfo>
    <lm:country>United Kingdom</lm:country>
    <lm:city>London</lm:city>
    <lmostalCode>WC2H 9HU</lmostalCode>
    <lm:district></lm:district>
    <lm:street>Earlham Street</lm:street>
    </lm:addressInfo>
    </lm:landmark>
    </lm:landmarkCollection>
    </lm:lmx>

    --boundary--

  5. #5
    Nokia Developer Champion
    Join Date
    Mar 2003
    Posts
    4,104
    Why do you send it as multipart? Is that a requirement in your situation? I created a link in my (X)HTML page to the Nokia Landsmark file, clicked on that with the internal browser, and if I recall correctly (do not have the device at hand right now) I was able to download and import it this way. No further headers.

  6. #6
    Registered User
    Join Date
    Feb 2008
    Posts
    4

    Re: Landmark HTTP response

    never mind, I got it already addtype was the key. thanks
    Last edited by mmogilnicki; 2008-02-09 at 18:05.

Similar Threads

  1. waiting for HTTP POST response
    By gemilib in forum Symbian C++
    Replies: 3
    Last Post: 2007-11-19, 17:00
  2. Problem retreiving custom HTTP response header
    By hmeet2 in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2007-01-03, 09:35
  3. Receive uncomplete HTTP response
    By apitoman in forum Symbian Networking & Messaging (Closed)
    Replies: 6
    Last Post: 2004-03-24, 16:15
  4. nokia 7210 modem via IR doesn't work !
    By oussamaaiadi in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2003-03-06, 10:46
  5. Replies: 1
    Last Post: 2002-07-22, 07:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •