×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Aug 2006
    Location
    Egypt, Cairo
    Posts
    37

    HTTP Client Problem

    Hello Every one

    i have a problem if any one can help me,

    iam using http client engine to connect to a webservice

    iam connecting twice after the first time after receiving the whole response i call a function to parse the response in the MHFRunL() in case THTTPEvent::ESucceeded
    then i delet the connection client and begain another one to make the same operation but in the second time it produce an error (it may first in the first time randomly)
    the error message is:
    access violation reading location 0x00000000

    you can see the error message in this path
    http://imajr.com/err.bmp-789824
    or
    http://img181.imageshack.us/my.php?image=errkw3.png

    please any one can help
    Regards,
    Fathi S. el3ashery

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: HTTP Client Problem

    that looks like a NULL pointer that you are trying to use, so best thing is to locate the line and see what is going wrong in there.

  3. #3
    Registered User
    Join Date
    Aug 2006
    Location
    Egypt, Cairo
    Posts
    37

    Re: HTTP Client Problem

    hi symbianyucca
    thanks for reply

    this error happen randomly, so in the same piece of dode it works som times and some times not

    if it is a null pointer then it will result a Error Exec 3 but i dont know what is the problem

    you have any suggestion??
    Regards,
    Fathi S. el3ashery

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: HTTP Client Problem

    try checking each pointer just before you use, also make sure you set any pointer to null after you delete it, and if it is still there, then you just need to build logging code in it, or some other way figure out the object who is gicing you the problem.

Similar Threads

  1. Datagram client port problem
    By khalandar in forum Mobile Java Networking & Messaging & Security
    Replies: 4
    Last Post: 2007-03-26, 06:07
  2. Http client api, animation delay
    By 1xuname1x in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2004-10-11, 07:40
  3. Problem with Authentication filter in HTTP Client API on Series 60 2.x
    By william_j in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2004-09-06, 13:15
  4. Replies: 2
    Last Post: 2003-11-09, 14:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×