×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Super Contributor
    Join Date
    Mar 2003
    Posts
    1,733

    Content-type: ?? from perl CGI script?

    Posted by Paul Reilly, paul@ireland.seds.org
    on August 29, 2000 at 18:16

    Whats the correct content-type to send form a cgi script which outputs wml? I've tried the following to no avail:

    print "Content-type:text/vnd.wap.wml n";
    print <
    n";
    print <:
    version="1.0"?>
    PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
    "http://www.wapforum.org/DT$
    online?">

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Posts
    1,733

    RE: Content-type: ?? from perl CGI script?

    Posted by Miika Tuisku, miika.tuisku@cern.ch
    on August 31, 2000 at 17:47



    I use ...
    ----
    use CGI;
    my $query = new CGI;
    my $len = length($msg);
    print $query->header(-type=>'text/vnd.wap.wml',
    -content_length=>"$len",
    -cache_control=>'max-age=0');
    print $msg;

    ---
    Additionally you should configure the right MIME types
    to your Web server ('text/vnd.wap.wml' etc ...)

  3. #3
    Super Contributor
    Join Date
    Mar 2003
    Posts
    1,733

    RE: Content-type: ?? from perl CGI script?

    Posted by john haselden, john.haselden@autotrader.co.uk
    on September 08, 2000 at 13:06



    Try:

    print "Content-type: text/vnd.wap.wmlnn";

    The 2 n's are very important.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •