×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Mar 2008
    Posts
    60

    Bug in TRK? - it can only install OR debug

    Hello!

    I have a problem with debugging with TRK.
    It refers to the option "Install for each debug session".
    If it's activated, my signed sis file installs in the phone when I press "debug", but than I get the message

    "Unable to install the application. Please sign the sis file with the right certificate. Also check the UID and make shure it is not already used."

    Ok, if I've done so and than deactivate the option, debugging works!

    BUT: If the option is not activated and the program is not installed on the phone, I get the message

    "Failed to create the new process."


    All I want is that when I hit the debug button, the currently installed version is overwritten with the new one and the debug process starts.

    How can I do that? Please help me!

    Greetings!

  2. #2
    Regular Contributor
    Join Date
    Mar 2008
    Posts
    60

    Re: Bug in TRK? - it can only install OR debug

    I just found out, that this error about the UID always raises if the TRK tries to install or re-install the debug application.
    It seems as if the installation takes place, however, the error is raised and so the debug session is stopped.

    Any ideas about that?

  3. #3
    Regular Contributor
    Join Date
    Mar 2008
    Posts
    60

    Re: Bug in TRK? - it can only install OR debug

    Ok, now i found out, that the problem only appears with the imported helloWorldBasic.
    It doesn't occur with a new CW project.

    Any helps?

  4. #4
    Regular Contributor
    Join Date
    Feb 2006
    Location
    India,Pune
    Posts
    311

    Re: Bug in TRK? - it can only install OR debug

    Quote Originally Posted by mg_at_uni View Post
    Ok, now i found out, that the problem only appears with the imported helloWorldBasic.
    It doesn't occur with a new CW project.

    Any helps?

    See: http://www.newlc.com/Carbide-c-Setti...On-Target.html

    Regards,
    Parag Purkar

  5. #5
    Regular Contributor
    Join Date
    Mar 2008
    Posts
    60

    Re: Bug in TRK? - it can only install OR debug

    Thanks for the answer. Sadly I've already read this.

    There's no problem with the debugging itself, it works perfect for my own projects (after some adaptions), but I get the mentioned problem with the imported helloWorldBasis.

    Btw. I'm using CodeWarrior, but I tried, its the same with Carbide.c++

Similar Threads

  1. Carbide.J 1.5 Vista Install Problem
    By Jimmmeh in forum Mobile Java Tools & SDKs
    Replies: 12
    Last Post: 2008-01-07, 10:32
  2. Install a sis file on a N80 phone
    By kaiten-sushi in forum Symbian
    Replies: 20
    Last Post: 2007-02-06, 12:24
  3. 1.3.11 will not install, 1.3.8 still will.
    By iemorgan in forum Symbian
    Replies: 0
    Last Post: 2006-10-14, 02:41
  4. SIS install fails in S60 V3
    By Holler in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 5
    Last Post: 2006-09-15, 03:03
  5. Problem of install nokia_c110 on linux
    By nonexist in forum Multimodecards
    Replies: 1
    Last Post: 2002-12-13, 10:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×