×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2008
    Posts
    3

    Need help in running framework "Symbian Test Unit"

    Framework used:
    Symbian Test Unit

    Other tools:
    Symbian S60 Series SDK
    Visual Studio 2005

    Problem Description:
    I downloaded an example package for Symbian test unit from the site www.bughuntress.com . Prior to running the example it is said that you have to build the project using makmake utility. Then use Visual Studio to perform the next "build" operation and then run the project.


    I placed the downloaded zip file inside the "Symbian" directory in my C drive. Then I extracted the file.

    The given package consists of a file named SymbainUnit.mmp. In the readme file it is said that, it is this file that has to be built. I gave the command "makmake SymbianUnit.mmp wins" to build the file. Consequently, building is done but some warnings are shown as follows:

    1. "Cannot determine the version of the RVCT complier"
    2. "#pragma once" is obsolete (this warning comes for several .h files)

    But I do not think these are major warnings. My main problem is what comes after this.

    After the file has been built I give the command "nmake -f Symbianunit.wins" to run the file.

    The following error messages are shown:

    Copyright (C) Microsoft Corporation. All rights reserved.

    perl -S emkdir.pl
    "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\build\vc71_symbian\SymbianUnit\
    WINS\UDEB"

    Can't find emkdir.pl on PATH.
    NMAKE : fatal error U1077: 'C:\Perl\bin\perl.EXE' : return code '0x2'

    Stop.

    Can't solve the above problem. So please help.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Need help in running framework "Symbian Test Unit"

    maybe you should visit the "Getting Started" pages, and have a loon also to the IDE options for building applications.

  3. #3
    Registered User
    Join Date
    Mar 2008
    Posts
    3

    Re: Need help in running framework "Symbian Test Unit"

    Hello,
    Thank you for your reply. The server for www.bughuntress.com is not responding, so I will try to see it later whether they have online "Getting started" materials. I read the readme files those were with the downloaded package but it is not of any help. The building done from inside the IDE will fail if the initial building is not done successfully(that is using the makmake utility).

    The thing is that I have to test symbian applications. Now, I need a framework (for Symbian C++ apps)that is easy to learn and useful. We are mainly looking for frameworks or software those are free. It will be very helpful if you could suggest some names, and how I can learn them.

    I tried Symbian OS unit. But there also I am facing the problem of building the given project using the command (bldmake bldfiles and abld makefile vc6).

    All I need is the name of a good tool and some guidance.

    Thanking you again.

    Ishtiyaq

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,696

    Re: Need help in running framework "Symbian Test Unit"

    My guess would be that Jukka meant the Getting started guide on this site. You can check the Wiki, and the main site as well.
    In a nutshell: recent S60 SDK-s cannot cooperate with Visual Studio directly, you need Carbide.vs for that.

  5. #5
    Registered User
    Join Date
    Mar 2008
    Posts
    3

    Re: Need help in running framework "Symbian Test Unit"

    Thank you to both of you. I have found a tutorial for Symbian OS unit in the Nokia Forum site.

    I am starting today. If there is any problem I will contact you.

    Wish me luck

    Ishtiyaq

Similar Threads

  1. breakpoints disabled when running debugger.
    By nawkboy in forum Symbian
    Replies: 4
    Last Post: 2012-05-31, 10:45
  2. test framework and socket connection problems
    By nawkboy in forum Symbian
    Replies: 3
    Last Post: 2007-02-23, 04:28
  3. test framework and socket connection problems
    By nawkboy in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2003-02-22, 00:03
  4. breakpoints disabled when running debugger
    By nawkboy in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2003-02-20, 03:43
  5. Replies: 0
    Last Post: 2003-02-11, 04:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×