×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Nokia Developer Champion
    Join Date
    Nov 2007
    Location
    Rome, Italy
    Posts
    2,406

    SDK Winsock and bluetooth remote connection

    Hi,

    I'm using S60 3rd MR Emulator. I use a bluetooth remote connection (using a Nokia E70) to connect to Internet, but when the emulator tries to connect to network, using Winsock, it simply doesn't connect at all.

    I've done several checks, but without success..

    Any hints would be highly appreciated!!

    Thanks,
    Pit

  2. #2
    Super Contributor
    Join Date
    Jan 2008
    Location
    Bangalore, India
    Posts
    777

    Re: SDK Winsock and bluetooth remote connection

    Quote Originally Posted by jappit View Post
    Hi,

    I'm using S60 3rd MR Emulator. I use a bluetooth remote connection (using a Nokia E70) to connect to Internet, but when the emulator tries to connect to network, using Winsock, it simply doesn't connect at all.

    I've done several checks, but without success..

    Any hints would be highly appreciated!!

    Thanks,
    Pit
    have u enabled internet on ur emulator.
    if not,do it from tools->device connection
    Regards
    $-Nitesh-$

  3. #3
    Nokia Developer Champion
    Join Date
    Nov 2007
    Location
    Rome, Italy
    Posts
    2,406

    Re: SDK Winsock and bluetooth remote connection

    Hi Nitesh,

    I've always used Emulator with WLAN, and it has always worked. Now i must use it via remote connection, and this problem arised. Anyway, when I try to open Tools -> Preferences or Tools -> Diagnostics I receive this message "Cannot start Ecmt Manager", so I'm not able to set any options..

    Pit

  4. #4
    Super Contributor
    Join Date
    Jan 2008
    Location
    Bangalore, India
    Posts
    777

    Re: SDK Winsock and bluetooth remote connection

    Quote Originally Posted by jappit View Post
    Hi Nitesh,

    I've always used Emulator with WLAN, and it has always worked. Now i must use it via remote connection, and this problem arised. Anyway, when I try to open Tools -> Preferences or Tools -> Diagnostics I receive this message "Cannot start Ecmt Manager", so I'm not able to set any options..

    Pit
    do like this,
    program menu->S60 developer Tools->3rd Edition->1.0->Tools->Device connection
    Regards
    $-Nitesh-$

  5. #5
    Nokia Developer Champion
    Join Date
    Nov 2007
    Location
    Rome, Italy
    Posts
    2,406

    Re: SDK Winsock and bluetooth remote connection

    Thanks Nitesh,

    I've opened up the Device Connectivity Tool, and it shows various COMs. Anyway, when trying to connect to COM used by bluetooth remote connection (COM40), the tool does nothing. I'm able to connect other ports (from COM3 to COM7, it seems), but using that did not solve my problem

    Pit

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: SDK Winsock and bluetooth remote connection

    That tool has nothing to do with your Internet connection. The emulator should be able to use any network connection that windows uses and the only relevant setting would be the proxy server.

    See http://discussion.forum.nokia.com/fo...t+Ecmt+Manager and then try to configure the proxy in the emulator preferences.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  7. #7
    Nokia Developer Champion
    Join Date
    Nov 2007
    Location
    Rome, Italy
    Posts
    2,406

    Re: SDK Winsock and bluetooth remote connection

    Thanks Itomuta,

    I read the linked post, but mine is not a proxy problem, since my remote connection doesn't use any. Could it be a problem with Winsock access point settings?

    Thanks again,
    Pit

Similar Threads

  1. error WSAEWOULDBLOCK in bluetooth socket
    By habier in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2006-08-02, 02:04
  2. Bluetooth connection with PC
    By AzuManga in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2005-12-05, 20:15
  3. Sony Vaio PCG-Z1SP and 6310i no PC Suite Connectivity
    By bealers in forum Bluetooth Technology
    Replies: 4
    Last Post: 2003-06-02, 15:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×