×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2008
    Posts
    5

    Question AT+CCFC problem ,tks

    Hello everybody:

    I want to achieve call forwarding usd the AT command -- AT+CCFC , S60 2nd.

    when I send "AT+CCFC=?",it return "+CCFC0-5) ok"
    and "AT+CCFC=0,2" return "+CCFC:0,7 ok"

    but when I send "AT+CCFC=0,3,"13800000000",129",it return ERROR,
    and so does "AT+CCFC=1,3,"13800000000",129"

    It happened on N90,N72,3230,but not on 6260

    need your help.

    thanks a lot~

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: AT+CCFC problem ,tks

    I have only tried this with 3rd ed devices (N73 & N95) and did not have any problems. So check with different SIM cards (maybe different networks), and try different values in different places (for exmaple check what is default, and other possible values that could be used instead of 129)

  3. #3
    Registered User
    Join Date
    Mar 2008
    Posts
    5

    Re: AT+CCFC problem ,tks

    Quote Originally Posted by symbianyucca View Post
    I have only tried this with 3rd ed devices (N73 & N95) and did not have any problems. So check with different SIM cards (maybe different networks), and try different values in different places (for exmaple check what is default, and other possible values that could be used instead of 129)
    Hello yucca:

    Glad to see your reply~ thx~

    I changed my SIM card to another one(different kinds),and my app work well when "AT+CCFC=0,3,******",but not"AT+CCFC=1,3,******"

    So,what's the problem about this case?(I meens about different SIM card)

    SIM not support?

    If Y, what can I do ? Is there another way(s) to deal with CALL FORWARDING?

    Do you think the "SetCallForwardingStatus()"can be competent for this?(I try this method but return -6 at all times)

    thanks a lot!!

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: AT+CCFC problem ,tks

    Some networks could in theory block this, but if you can use phones own call forwarding settings then the network should be ok.

    Anyway, check all different options you can use, and see which one would work, lost of work but sometimes nesessary.

    SetCallForwardingStatus() is propably part of an API that is symbian owned, thus you should ask them for verification on the working with that API. -6 means that your argument values are non-correct, thus check and re-check that you have supplied correct values.

  5. #5
    Registered User
    Join Date
    Mar 2008
    Posts
    5

    Re: AT+CCFC problem ,tks

    [QUOTE=symbianyucca;400943]Some networks could in theory block this, but if you can use phones own call forwarding settings then the network should be ok.

    When dial "**67*1245678#", I can set the Call Forwarding easily.
    and so does cancel it use "##67#"

    but I can't do this by sending "AT+CCFC=...."

    Any suggestion?

    And I'll test other method ^_^

Similar Threads

  1. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  2. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  3. WAP service problem on Apache
    By bigg_o in forum Browsing and Mark-ups
    Replies: 3
    Last Post: 2005-04-17, 16:05
  4. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×