×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Mar 2008
    Posts
    28

    Emulator in debug mode crashed with Carbide C++ 1.3 and SDK 3rd (3.0)

    Hi all,
    When I run my app in normal mode, the emulator starts fine, but my app gets "Apps. closed". Ok , that's fine because my app probably uses too much memory (HEAPSIZE set to 64M)

    Now when i run it in Debug mode, the emulator crashes with the following message in the console

    --->
    Thread SysAgt2Svr.exe::Main created @ 0xa89a60 - Win32 Thread ID 0xc3c
    8.100 Thread WSERV.EXE::Main created @ 0xa8b4d0 - Win32 Thread ID 0x7f8
    8.230 Thread fbserv.exe::Main created @ 0xa8bd30 - Win32 Thread ID 0xdac
    8.260 Thread fbserv.exe::!Fontbitmapserver Panic FBSERV -15
    8.260 FAULT: KERN 00000004

    <--

    My environment:
    Carbice C++ 1.3
    SDK 3.0 (Symbian 9.1)

    Any ideas every one? Thanks a lot in advance

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,144

    Re: Emulator in debug mode crashed with Carbide C++ 1.3 and SDK 3rd (3.0)

    Try to check which line causes the crash, and if there is any errors you could catch.


    FBSERV panics can be found from here: http://www.symbian.com/developer/tec...ERVPanics.html

    though for 15, it doe not give any nice answers.

  3. #3
    Registered User
    Join Date
    Mar 2008
    Posts
    28

    Re: Emulator in debug mode crashed with Carbide C++ 1.3 and SDK 3rd (3.0)

    Quote Originally Posted by symbianyucca View Post
    Try to check which line causes the crash, and if there is any errors you could catch.
    I have tried to all the break points in all the Constructors of my app, but it still crashes right away, so it's kinda hard to catch

    Also, I might add here the messages in the Debug window:

    --->
    Thread [Thread id: 3756] (Suspended: Signal 'Halt' received. Description: User halted thread.)
    22 0x8FBA12( ekern.exe )() 0x008fba12
    21 0x8FBB61( ekern.exe )() 0x008fbb61
    20 0x92D794( ekern.exe )() 0x0092d794
    19 0x92D9D1( ekern.exe )() 0x0092d9d1
    18 0x93444E( ekern.exe )() 0x0093444e
    17 0x93427A( ekern.exe )() 0x0093427a
    16 0x8F2B09( ekern.exe )() 0x008f2b09
    15 0x8F1FC8( ekern.exe )() 0x008f1fc8
    14 0x8F1287( ekern.exe )() 0x008f1287
    13 0x8F34D2( ekern.exe )() 0x008f34d2
    12 0x934891( ekern.exe )() 0x00934891
    11 0x926D67( ekern.exe )() 0x00926d67
    10 0x8F42B5( ekern.exe )() 0x008f42b5
    9 0x8F422B( ekern.exe )() 0x008f422b
    8 0x6005B149( euser.dll )() 0x6005b149
    7 0x6001DBE9( euser.dll )() 0x6001dbe9
    6 0x83554E6( FBSERV.EXE )() 0x083554e6
    5 0x83558AE( FBSERV.EXE )() 0x083558ae
    4 0x835C4BF( FBSERV.EXE )() 0x0835c4bf
    3 0x8FA6A2( ekern.exe )() 0x008fa6a2
    2 0x8F8AD1( ekern.exe )() 0x008f8ad1
    1 0x7C80B683( KERNEL32.dll )() 0x7c80b683
    <---

    And this in the "Editor" window
    --->
    No source available for "0x7C80B683( KERNEL32.dll )() "
    <---

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: Emulator in debug mode crashed with Carbide C++ 1.3 and SDK 3rd (3.0)

    Quote Originally Posted by symbianyucca View Post
    though for 15, it doe not give any nice answers.
    It is not 15, it is -15. However KErrServerTerminated still does not add real important details, I admit.

    Do you want anything from FBS, or this panic just happens? If your application does not even start, you may try removing your application icons as a first step.

  5. #5
    Registered User
    Join Date
    Mar 2008
    Posts
    28

    Re: Emulator in debug mode crashed with Carbide C++ 1.3 and SDK 3rd (3.0)

    I am indeed reading an image from file and do some drawing with its bitmap.
    The image manipulation takes quite a lot of memory.

    There are 2 things in my mind:
    1. How much memory should MAXHEAPZISE be? Why is it only 1M by default? Isn't this too little? What is the reasonable value for an application? For a Nokia N7x or 8x, its free executable memory is around 18M
    And if I set the MAXHEAPSIZE of to 128M, can the emulator really allocate 128M? I kinda doubt it
    (My computer has 1G RAM)

    2. Now, if i run my app through Carbide C++, it dies immediately, like described, regardless it's in normal or debug mode.
    HOWEVER, if i run the emulator from the epoc.exe in
    C:\Symbian\9.1\S60_3rd\Epoc32\release\winscw\udeb
    then i can start my app(it still crashes due to memory when running though)
    Is this the problem of Carbide C++?

    Thanks for reading everyone.
    Last edited by hoangtv1; 2008-03-31 at 04:01.

  6. #6
    Registered User
    Join Date
    Mar 2008
    Posts
    28

    Re: Emulator in debug mode crashed with Carbide C++ 1.3 and SDK 3rd (3.0)

    I reinstalled the SDK 3rd, and now the emulator seems to be fine. Some kinda weird stuff must have happned!

Similar Threads

  1. sdk 2.1 to sdk 3.0 compatibility
    By veciofio in forum PC Suite API and PC Connectivity SDK
    Replies: 2
    Last Post: 2003-11-25, 21:55
  2. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43
  3. Series 60Series 60 MIDP Concept SDK Beta 0.2 Linux bug?
    By kauppi in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2003-04-07, 09:05
  4. 6360 analog operation using PC Connectivity SDK 3.0
    By danielbartozzi in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2003-03-24, 03:19
  5. Http connection problem in 6310i
    By teahola in forum Mobile Java General
    Replies: 1
    Last Post: 2002-10-03, 18:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •