×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Feb 2008
    Posts
    5

    Exiting to the shell

    Hi, I'm having a lot of difficulty figuring out what I'm doing wrong..

    Basically when my application exits it returns to the phone's application menu rather than exiting to the shell, the previous version of my app did return to the shell and that is the behaviour of the example apps, however I can't see what I've done that would change this behaviour.

    I've included my source code which is a bit long but I don't know where to start, I've just started learning OO concepts so it could be any number of things.

    Thanks in advance.

    Source Code - http://rafb.net/p/HXzjwn96.html

  2. #2
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: Exiting to the shell

    Hello,

    I haven't tried your script on a device but I strongly believe the problem is in line 45 (appuifw.app.set_exit()). By giving the set_exit() instruction you tell the Python interpreter to close (and thus you are returned to the phone's menu). Remove that line and leave only self.app_lock.signal(). That should make it close and return you to the Shell.

    Again, I haven't tested it, so I'm sorry if it's not the answer you were looking for. Let us know if it works

  3. #3
    Registered User
    Join Date
    Feb 2008
    Posts
    5

    Re: Exiting to the shell

    Hey Bogdan,

    Thanks for your help, I commented it out and it worked.

    -James

Similar Threads

  1. Nokia NFC shell and PN531 communication
    By rudieschonenberg in forum Near Field Communication
    Replies: 33
    Last Post: 2007-11-17, 07:09
  2. Nokia 5140, GPS Shell and JSR179 (Location/GPS API)
    By hziegler in forum Mobile Java General
    Replies: 18
    Last Post: 2007-03-15, 07:41
  3. Can't read RFID Tag with NFC Shell
    By begermic in forum Mobile Java Tools & SDKs
    Replies: 5
    Last Post: 2007-01-31, 23:02
  4. NFC Shell
    By mpcoloma in forum General Development Questions
    Replies: 1
    Last Post: 2007-01-31, 10:34
  5. weird text shell problem
    By jzxu in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2006-12-03, 21:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×