×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Regular Contributor
    Join Date
    Mar 2008
    Posts
    77

    '\n' can not make a new line in CEikEdwin, Why?

    iEdit1->SetTextL( _L("aaaaaaaa\nfffffffff") );

    display "aaaaaaaa fffffffff" in EDWIN control, the '\n' character change to a BLANK character, not new line. I try "\r\n" still not work.

    How to make new line in EDWIN control?

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: '\n' can not make a new line in CEikEdwin, Why?

    Yep, known issue really, and discussed plenty of times. Basically you need to add the linebreak into the richtext object.

  3. #3
    Nokia Developer Champion
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    1,572

    Re: '\n' can not make a new line in CEikEdwin, Why?

    The new line characters in Symbian are :

    0x2029 - returns char in symbian
    0x2028 - newline in symbian

    0x000D - return char in windows (\r)
    0x000A - newline in windows (\n)


    hope this helps !
    Amit Kankani
    Nokia Developer Champion

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: '\n' can not make a new line in CEikEdwin, Why?

    Check CEditableText in the SDK Help, and there you will find an anonymous enumeration containing some of these special characters at the end of the page.

Similar Threads

  1. 860726 - Getting started with Carbide C++
    By ilostmyid2 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2007-10-24, 06:05
  2. compilation error: identifier redeclared
    By netra in forum Symbian
    Replies: 2
    Last Post: 2007-06-22, 10:42
  3. Compilation series 60 3rd edition
    By asmobease in forum Symbian Tools & SDKs
    Replies: 32
    Last Post: 2006-09-13, 09:46
  4. Compilation series 60 3rd edition
    By asmobease in forum Symbian
    Replies: 3
    Last Post: 2006-09-10, 14:08
  5. problem with Code Warrior 5.2
    By mayankkedia in forum Symbian
    Replies: 4
    Last Post: 2006-06-22, 08:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×