×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2008
    Posts
    25

    Angry Problem with browser

    Hi,

    Firstly i have read all the previous posts but to no avail.

    I simply want to open the browser from my python script. I can connect to my wifi no problem. here is my script.

    Code:
    import e32
    import os
    import socket   
      
    ap_id = socket.select_access_point()   
    apo = socket.access_point(ap_id)   
    socket.set_default_access_point(apo)
    
    path = 'z:\\System\\Apps\\Browser\\Browser.app'
    apprun = 'z:\\system\\programs\\apprun.exe'
    
    def open(url):
       apprun_arg = path + ' "' + url + '"'
       e32.start_exe(apprun,apprun_arg, 1)
    
    open("http://www.google.co.uk")
    print "done"
    Somebody else posted this and said it workled. Im really stuck with this. Any help appreciated.

    I also tried webbrowser, i would prefer to use it this way though.

    Thanks

  2. #2
    Registered User
    Join Date
    Mar 2008
    Posts
    25

    Re: Problem with browser

    i dont know whats wrong to be honest..

    this worked for me though so hopefully it helps someone else


    http://wiki.forum.nokia.com/index.ph...rogrammaticaly

Similar Threads

  1. Problem MMC+USB Connection
    By Fede81 in forum Symbian
    Replies: 1
    Last Post: 2007-06-14, 06:13
  2. browser: problem in device
    By ctrl-d in forum Symbian
    Replies: 0
    Last Post: 2007-03-07, 23:20
  3. Problem MMC+USB Connection
    By Fede81 in forum General Development Questions
    Replies: 3
    Last Post: 2006-07-19, 15:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×