×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Super Contributor
    Join Date
    Apr 2007
    Posts
    2,708

    IllegalArgumentException: Null URI

    Him
    I am getting a meesage of an uncaught IllegalArgumentException: Null URI...
    This is happening around the time I am using the Bluetooth API and the RMS API... I have looked on the net but no info is available regarding this specific error, so I was wondering if anyone had any experience with it and maybe knows which kind of method calls (in the above-mentioned API's) can throw this exception....

    thx in advance

  2. #2
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: IllegalArgumentException: Null URI

    Check first the method calls you use to open the bluetooth connection. The Exceptioon you get is quite general ("Thrown to indicate that a method has been passed an illegal or inappropriate argument."), it looks like you have one of the parameters (the URI) you are passing to some method call as not defined...

    But in general, first you need to debug your code more, and if that does not help, you have to provide more information about the problem.

    Hartti

  3. #3
    Super Contributor
    Join Date
    Apr 2007
    Posts
    2,708

    Re: IllegalArgumentException: Null URI

    true,
    but as far as i know no parameter called URI is used in my own interface towards the before mentioned J2ME API's (RMS and BT) and also i havent found any documentation regarding anything of an URI in those API's....

    debugging as known is hell on J2ME, especially with Bluetooth !
    On the Emulator I dont get any error, but on the mobile phone itself (N95) I do and I actually get a Symbian-thrown Alert telling me there has been an uncaught exception... Then I look at another midlet which catches all the system.out messages and then i can see what kind of exception it is (IllegalArgumentException)...

    so about the debugging part, I actually spend 2 full work-days trying to figure this out but with no result... The app runs fine on the S40 Nokia 6233 and the emulator...

  4. #4
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: IllegalArgumentException: Null URI

    Yes, I know that debugging is time-consuming and complicated on Java ME devices. However, if you could find a specific part of the code, which throws the exception, then we are much closer to some answers

    Hartti

Similar Threads

  1. Please its veru urgent on nokia 3250
    By siva_guduru in forum Mobile Java General
    Replies: 8
    Last Post: 2008-05-01, 10:24
  2. Video playback with sound but nothing on Screen
    By abdullah829 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 5
    Last Post: 2007-11-30, 14:04
  3. Connection problem with Nokia 6681.
    By hadhi631 in forum Mobile Java Networking & Messaging & Security
    Replies: 8
    Last Post: 2006-09-08, 21:45
  4. !Nokia QD UTF-8!
    By blueseaineye in forum [Archived] Other Programming Discussion 关于其他编程技术的讨论
    Replies: 1
    Last Post: 2006-03-13, 09:08
  5. global root overflow(please help)
    By sushant_125 in forum Mobile Java Networking & Messaging & Security
    Replies: 3
    Last Post: 2004-05-14, 08:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •